Closed Bug 989885 Opened 6 years ago Closed 6 years ago

text-shadow don't work when printing

Categories

(Core :: Printing: Output, defect)

11 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 991767
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- unaffected
firefox-esr24 --- affected

People

(Reporter: khadem1386, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Steps to reproduce:



to reproduction:

<!DOCTYPE html>
<html>
<head>
<style>
h1 {text-shadow:2px 2px  5px #FF0000;}
</style>
</head>
<body>

<h1>Text-shadow effect</h1>

<p><b>Note:</b>shadow not show on the paper or PDF or .... on last versions of firefox</p>

</body>
</html>


Actual results:

I have good printing (box and text) shadow on version 3.5 but not on new versions (till 28).
preview is good but not when really print, shadow is off when printing
 this problem exist between 13 to 28 version firefox.


Expected results:

printed paper has shadow like preview.
Status: UNCONFIRMED → NEW
Component: Untriaged → Printing: Output
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Version: 28 Branch → 11 Branch
Regression:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8531b4bf5cb9&tochange=5549f4202af8

Suspect :Joe Drew — Bug 685767 - Factor blurring out into its own class, and use it from gfxAlphaBoxBlur. r=mattwoodrow
Blocks: 685767
OS: Windows XP → All
thanks for your answer 
could you please say how can I set
on my css?
gfxAlphaBoxBlur. r=mattwoodrow


I don't understand solution 

is this a bug or what is solution ?

Thanks a gain  "Alice0775 White"
I cannot reproduce the problem in Firefox30.0b9.

Could you try Firefox30.0b9.
This was fixed by Bug 991767
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 991767
Resolution: --- → DUPLICATE
Duplicate of bug: 991767
You need to log in before you can comment on or make changes to this bug.