Closed Bug 990036 Opened 6 years ago Closed 5 years ago

[User Story] Vertical Homescreen Tutorial Outside of FTE

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

x86
macOS
defect

Tracking

(feature-b2g:2.0, tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 939174
2.0 S3 (6june)
feature-b2g 2.0
tracking-b2g backlog

People

(Reporter: pdol, Assigned: sfoster)

References

Details

(Keywords: feature, Whiteboard: [ucid:System178, ft:systemsfe, 2.0],[p=5])

User Story

As a user who has updated my OS, I want a tutorial to inform me how to use the new vertical homescreen to help me avoid confusion with the new interaction.

Acceptance Criteria:
1. After updating to the new OS version which includes the vertical homescreen, I am visually informed how to interact with the new homescreen, as per UX spec.
No description provided.
User Story: (updated)
blocking-b2g: --- → backlog
Whiteboard: [ucid:System178], [ft:systemsfe] → [ucid:System178, ft:systemsfe, 2.0]
Whiteboard: [ucid:System178, ft:systemsfe, 2.0] → [ucid:System178, ft:systemsfe, 2.0],[p=5]
feature-b2g: --- → 2.0
Flags: in-moztrap?(jlorenzo)
Do we have the visuals ready for this?
Flags: needinfo?(firefoxos-ux-bugzilla)
Assignee: nobody → sfoster
As per bug 990035, we had initial designs and visuals. However, as a result of the usability study feedback, Jacqueline is currently redesigning the screens. She will sync up with Sam early next week.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(jsavory)
Priority: -- → P1
Target Milestone: --- → 2.0 S2 (23may)
The need to use video snippets in 2.0, but keep the existing image sequence for tablets means this should build on the new generic & configurable tutorial work in bug 939174.
Depends on: 939174
Target Milestone: 2.0 S2 (23may) → 2.0 S3 (6june)
Depends on: 1017314
Summary of updates to tutorial flow - including the update scenario - are captured in this spec from :jsavory https://mozilla.app.box.com/s/m593btokr997r3o5ggvr
Jacqueline: In the WIP on this I can provide a config for upgrades by point-release. So, e.g. 1.3 -> 2.0, 1.4 -> 2.0. Do we want to show the same (vertical scroll + move icon, sheets) steps for a 1.3 -> 2.0 upgrade as 1.4 -> 2.0? I assume for < 1.3 we'll just show the whole tutorial?
QA Whiteboard: [VH-FL-blocking+]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939174
Sam and I have already discussed the question previously, all update versions will include the same information. Clearing flag.
Flags: needinfo?(jsavory)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.