Closed Bug 990384 Opened 7 years ago Closed 7 years ago

Define tabToolbarNavbarOverlap to reduce magic numbers

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: MattN, Assigned: MattN)

References

Details

(Whiteboard: [Australis:P5][qa-])

Attachments

(1 file)

Seperating the tabToolbarNavbarOverlap change out of bug 946987 since bug 990218 also wants it and it's good to do regardless of how bug 946987 ends up.
I forget exactly why I switched from margin-bottom to using background-position for bug 946987 but regardless adjusting the background-position makes sense to me.
Attachment #8399794 - Flags: review?(mconley)
Blocks: 990387
Comment on attachment 8399794 [details] [diff] [review]
v.1 Replace 1px with @tabToolbarNavbarOverlap@ (and one margin => background-position)

Review of attachment 8399794 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM - thanks for factoring that stuff out.
Attachment #8399794 - Flags: review?(mconley) → review+
https://hg.mozilla.org/integration/fx-team/rev/cbae8e109808
Keywords: checkin-needed
Whiteboard: [Australis:P5] → [Australis:P5][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/cbae8e109808
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P5][fixed-in-fx-team] → [Australis:P5]
Target Milestone: --- → Firefox 31
Comment on attachment 8399794 [details] [diff] [review]
v.1 Replace 1px with @tabToolbarNavbarOverlap@ (and one margin => background-position)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Multiple bugs using hardcoded "1px"
User impact if declined: More fragile UI leading to potential breakages from future changes
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk mostly swapping hardcoded "1px" for a define
String or IDL/UUID changes made by this patch: None
Attachment #8399794 - Flags: approval-mozilla-beta?
Attachment #8399794 - Flags: approval-mozilla-aurora?
Attachment #8399794 - Flags: approval-mozilla-beta?
Attachment #8399794 - Flags: approval-mozilla-beta+
Attachment #8399794 - Flags: approval-mozilla-aurora?
Attachment #8399794 - Flags: approval-mozilla-aurora+
Whiteboard: [Australis:P5] → [Australis:P5][qa-]
You need to log in before you can comment on or make changes to this bug.