Closed Bug 990494 Opened 6 years ago Closed 2 years ago

[Tarako][Camera][Lockscreen] The screen turns black after repeatly unlock screen and open camera from lockscreen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

Other
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-, b2g-v1.3T affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: bli, Unassigned)

References

Details

(Whiteboard: [perf-reviewed][sprd295029])

Attachments

(2 files)

Environment:
-------------------------------------------------
Gaia 769c3b00a43f03ca901414ec533f7b313a7684c5
Gecko 321494b801617a6bdf8260a483a80c0c09d49c4d
BuildID 20140401060054
Version 28.1
ro.build.version.incremental=76
ro.build.date=Tue Apr 1 06:43:27 CST 2014


Steps to reproduce:
--------------------------------------------------
1. Lock screen
2. Open the camera from lockscreen
   -->It takes a while for camera to get ready
3. Lock the screen before camera gets ready
4. Unlock screen
5. Repeat step 1 to 4 for several times.


Actual result:
--------------------------------------------------
The screen turn black.


Additional info:
---------------------------------------------------
This bug cannot be reproduced 100%. (A low rate of reproduction)
Need to try more times.
Can we get a screenshot here? Thanks!
Component: Gaia::System → Gaia::System::Lockscreen
Flags: needinfo?(bli)
Good catch! I've been able to reproduce this pretty reliably on 2/4 PVT build:

Gaia      cc0f31ec4509d5067bf155fd7ea38425dcbe39eb
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/c20ed9f97159
BuildID   20140401004001
Version   28.1
ro.build.version.incremental=76
ro.build.date=Tue Apr  1 06:43:27 CST 2014

Film attached of STR.  The result is just a black screen.
Attached video Video of STR
Flags: needinfo?(bli)
Checked also to see if this repros on 1.3; it doesn't.   Nomming for 1.3T as this is pretty serious.

Gaia      c5cd3a11e91339163b351d50769eaca0067da860
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/5045a67b47ed
BuildID   20140401164001
Version   28.0
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
blocking-b2g: --- → 1.3T?
Greg, might be a regression of bug 982530?
Flags: needinfo?(gweng)
Maybe not. I've found that the black screen is caused by the |#windows| itself. It even remains black after I delete the whole |#lockscreen| from AppManager, and before that I've checked that the |disable-cover| has been set as |display:none|. I also found that the camera app window would show with background image as 'undefined', but I don't know whether this is related.

I'll attach the AppManager screenshot later.
Flags: needinfo?(gweng)
Please continue looking into the cause in window management, thanks.
Assignee: nobody → gweng
Component: Gaia::System::Lockscreen → Gaia::System::Window Mgmt
Flags: needinfo?(gweng)
Of course I'll continue to investigate it. But Tim you may need to know it would take me some time to investigate it because we lack of Tarako device as you may know (I even need to borrow it from someone had borrowed from the owner), and I'm not familiar with v1.3T's window manager.
Flags: needinfo?(gweng)
how can the user recover from it if the black screen is seen? thanks
Flags: needinfo?(bli)
(In reply to Joe Cheng [:jcheng] from comment #10)
> how can the user recover from it if the black screen is seen? thanks

Press home button.
Flags: needinfo?(bli)
Since the reproduce rate of this bug is very low, and user can easily recover from it by pressing home button, I don't think this is a blocker.
agree. minus this bug
blocking-b2g: 1.3T? → -
Triage: This looks like a functional issue, not a performance issue. Marking as perf-reviewed.
Keywords: perf
Whiteboard: [perf-reviewed]
Priority: -- → P2
Whiteboard: [perf-reviewed] → [perf-reviewed][sprd295029]
Is it the same as bug 994590?
Depends on: 994590
blocking-b2g: - → 1.3T?
triage: minus as this is not easily reproduced, steven will discuss with partner
blocking-b2g: 1.3T? → -
Assignee: gweng → nobody
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.