Closed Bug 990560 Opened 7 years ago Closed 7 years ago

[Tarako][Marketplace] Marketplace exits when try to sign in with persona

Categories

(Firefox OS Graveyard :: Performance, defect, P3)

Other
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3T affected)

RESOLVED WONTFIX
1.4 S6 (25apr)
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: bli, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [c=memory p= s=2014.04.25 u=tarako] [MemShrink:P3], OOM)

Attachments

(4 files)

Environment:
-----------------------------------------------
Gaia 769c3b00a43f03ca901414ec533f7b313a7684c5
Gecko 321494b801617a6bdf8260a483a80c0c09d49c4d
BuildID 20140401060054
Version 28.1
ro.build.version.incremental=76
ro.build.date=Tue Apr 1 06:43:27 CST 2014


Steps to reproduce:
-----------------------------------------------
1. Launch Marketplace
2. Tap on 'settings' gear icon
3. Tap on 'Sign In / Sign Up'
4. wait for a while

Actual result:
----------------------------------------------
Marketplace app exits.
1.3T+ for feature not working on Tarako
Wil, is it something you can look at? Thanks
blocking-b2g: --- → 1.3T+
Flags: needinfo?(clouserw)
I've seen this work on two phones and never seen it fail, although I've also heard it fails from multiple people.  My suspicion is that several things are running, then the Marketplace is run, then when you click sign in the phone attempts to bring up the Trusted UI, decides it needs memory, and kills the Marketplace.

I don't know how to test the above scenario.
Flags: needinfo?(clouserw)
We need an about:memory report here.

Sending over to perf as this sounds like an issue with memory & process management.
Component: General → Performance
Keywords: perf, qawanted
Whiteboard: [MemShrink]
Keywords: smoketest
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
I tried getting Marketplace to run and all I see is the startup icon in today's build...

Gaia      769c3b00a43f03ca901414ec533f7b313a7684c5
Gecko     321494b801617a6bdf8260a483a80c0c09d49c4d
BuildID   20140401060054
Version   28.1
ro.build.version.incremental=76
ro.build.date=Tue Apr  1 06:43:27 CST 2014
Blocks: 991224
On tarako the LMK's min_free of foreground application is 4MB, which is almost impossible to get hit. So I guess it was killed by OOM killer, this can be confirmed from dmesg.
Whiteboard: [MemShrink] → [c=memory p= s= u=tarako] [MemShrink]
Apparently, we can't get about:memory reports on tarako pvtbuilds right now. There's a bug about this somewhere.
Keywords: qawanted
Whiteboard: [c=memory p= s= u=tarako] [MemShrink] → [c=memory p= s= u=tarako] [MemShrink], OOM
No longer reproducible in today's tarako build.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
So is this fixed?
Attached image signing-in.JPG
Attached image password screen.JPG
Attached image signed in screen.JPG
When I tried signing in, I did hit a timeout for persona but I was eventually successful with signing in.
I am reopening this bug because this issue still occurs. The repro rate is 3/7. I also generated a oom report which I have attached.
I tested on the latest PVT build on 1.3T and the latest base image sp6821.

1.3T Environmental Variables:
Device: Tarako
BuildID: 20140411004003
Gaia: 27a0e773e01eed74e20709bdcab6894469f42a72
Gecko: 257dd37da601
Version: 28.1
Firmware Version: sp6821
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [Tarako][Marketplace] Marketplace exits when try to sigin persona → [Tarako][Marketplace] Marketplace exits when try to sign in with persona
Unassigning this as I am currently not working it.  I'm busy with bug 987556 at the moment.
Assignee: bkelly → nobody
QAWANTED, let's test this after new marketplace lands this week
Keywords: qawanted
(In reply to Joe Cheng [:jcheng] from comment #15)
> QAWANTED, let's test this after new marketplace lands this week

This needs to actually land first before this gets flagged.
Keywords: qawanted
For several reasons, the marketplace that's landing this week (darjeeling v0) will have neither login nor Persona integration.

This testing should be deferred until such point as a tarako-capable marketplace with login is viable, or opened as a non-P1 testing against the non-darjeeling marketplace.
I'm going to pull the blocking flag & smoketest keywords because the marketplace shipping in Tarako will not have persona support, so this won't block 1.3T. We'll probably need to invalidate the Tarako test case here for 1.3T as well.
blocking-b2g: 1.3T+ → ---
Keywords: smoketest
Whiteboard: [c=memory p= s= u=tarako] [MemShrink], OOM → [c=memory p= s= u=tarako] [MemShrink:P3], OOM
Priority: P1 → P3
Tarako Marketplace will not support Persona.  Expect a new packaged app for Tarako shortly.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
Whiteboard: [c=memory p= s= u=tarako] [MemShrink:P3], OOM → [c=memory p= s=2014.04.25 u=tarako] [MemShrink:P3], OOM
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.