Closed Bug 990797 Opened 6 years ago Closed 6 years ago

TPS CI errors out when trying to e-mail results

Categories

(Testing Graveyard :: TPS, defect)

defect
Not set
normal

Tracking

(firefox29 wontfix, firefox30 fixed, firefox31 fixed)

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: jgriffin, Assigned: whimboo)

References

Details

(Keywords: regression)

Attachments

(1 file)

This occurs because this code tries to pull out some metadata from the logfile via regex's:

http://mxr.mozilla.org/mozilla-central/source/testing/tps/tps/testrunner.py#102

but the relevant strings have changed:

http://mxr.mozilla.org/mozilla-central/source/services/sync/tps/extensions/tps/resource/tps.jsm#567

This is admittedly probably not the best way for the e-mailer to find this information.  But, the easiest fix will be to change the regex's to match the new format.
Sorry, that's my fault. I will have a patch ready in a bit.
Assignee: nobody → hskupin
Blocks: 981848
Status: NEW → ASSIGNED
Component: Firefox Sync: Backend → TPS
Keywords: regression
Product: Mozilla Services → Testing
I agree that we should find something better but lets do it once we have the new CI in place in the next couple weeks. For now this will be sufficient.
Attachment #8400482 - Flags: review?(jgriffin)
Comment on attachment 8400482 [details] [diff] [review]
Corrected parsing of results

Review of attachment 8400482 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8400482 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/mozilla-central/rev/cb9095bf362e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8400482 [details] [diff] [review]
Corrected parsing of results

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 981848
User impact if declined: None, only for testing
Testing completed (on m-c, etc.): inbound, m-c
Risk to taking this patch (and alternatives if risky): None 
String or IDL/UUID changes made by this patch: None
Attachment #8400482 - Flags: approval-mozilla-aurora?
Comment on attachment 8400482 [details] [diff] [review]
Corrected parsing of results

[Triage Comment]
Given the low risk here and the affected on Beta, please also uplift there if it can land cleanly otherwise put up a new branch-specific patch for approval.
Attachment #8400482 - Flags: approval-mozilla-beta+
Attachment #8400482 - Flags: approval-mozilla-aurora?
Attachment #8400482 - Flags: approval-mozilla-aurora+
Flags: needinfo?(hskupin)
Flags: needinfo?(hskupin)
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.