Closed Bug 990979 Opened 6 years ago Closed 6 years ago

about:welcomeback is missing a CSS file on aero variant of the Windows theme

Categories

(Firefox :: Migration, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: Unfocused, Assigned: Unfocused)

References

Details

(Whiteboard: [good first verify])

Attachments

(1 file)

Someone forgot to add aboutWelcomeback.css to the aero section of jar.mn :)
Attached patch Patch v1Splinter Review
Attachment #8400477 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8400477 [details] [diff] [review]
Patch v1

Gijs is away still I think. I believe I reviewed this… oops.
Attachment #8400477 - Flags: review?(gijskruitbosch+bugs) → review+
It would be nice to uplift this as I believe it's replacing the warning icon with an info one and I don't think the warning icon is very friendly to users who just did a reset.
:-(
Whiteboard: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/7629b0acbed9
Whiteboard: checkin-needed → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7629b0acbed9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
Comment on attachment 8400477 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 833943
User impact if declined: Confusing icon in about:welcomeback (warning icon instead of info icon) on Windows (Vista and newer)
Testing completed (on m-c, etc.): Manual testing on Nightly
Risk to taking this patch (and alternatives if risky): Extremely minimal - it's only a packaging change
String or IDL/UUID changes made by this patch: None
Attachment #8400477 - Flags: approval-mozilla-beta?
Attachment #8400477 - Flags: approval-mozilla-aurora?
Attachment #8400477 - Flags: approval-mozilla-beta?
Attachment #8400477 - Flags: approval-mozilla-beta+
Attachment #8400477 - Flags: approval-mozilla-aurora?
Attachment #8400477 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/cd225df4767b
https://hg.mozilla.org/releases/mozilla-beta/rev/31aca79a5126

Manual verification will just involve manually opening about:welcomeback, and checking if the icon at the top of the page is an information icon instead of a warning icon.
Whiteboard: [good first verify]
Verified Fixed on Windows 8 64 Bit, Firefox 31 (2014-04-15)
Status: RESOLVED → VERIFIED
(In reply to Vuyisile Ndlovu [:terrameijar] from comment #9)
> Verified Fixed on Windows 8 64 Bit, Firefox 31 (2014-04-15)

Vuyisile, could you also verify this with the latest Firefox 29 (http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b8/) and latest Firefox 30 (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/)?
Ok I'll do that just now
I've verified this as fixed against Firefox 29 and 30.
(In reply to Vuyisile Ndlovu [:terrameijar] from comment #12)
> I've verified this as fixed against Firefox 29 and 30.

Marking as verified... thanks Vuyisile.
You need to log in before you can comment on or make changes to this bug.