TypeError: aIdsApp is undefined at OperatorApps.jsm:317

RESOLVED FIXED in Firefox 30

Status

defect
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: gwagner, Assigned: marco)

Tracking

unspecified
mozilla31
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

Reporter

Description

5 years ago
Seen on nexus 4 with current trunk and --enable-debug gecko build.

*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: aIdsApp is undefined
Full stack: this.OperatorAppsRegistry._installOperatorApps/<@resource://gre/modules/OperatorApps.jsm:317:23
TaskImpl_run@resource://gre/modules/Task.jsm:298:1
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118:11
then@resource://gre/modules/commonjs/sdk/core/promise.js:43:43
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:185:11
TaskImpl_run@resource://gre/modules/Task.jsm:307:9
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:748:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:627:7

*************************
Assignee

Comment 1

5 years ago
Posted patch Patch (obsolete) — Splinter Review
Could you try if this patch fixes your problem?
Assignee

Comment 2

5 years ago
Posted patch Patch (obsolete) — Splinter Review
Attachment #8400872 - Attachment is obsolete: true
Reporter

Comment 3

5 years ago
The exception is gone. But we done set PREF_FIRST_RUN_WITH_SIM now. Is this what we want?
Assignee

Comment 4

5 years ago
Posted patch Alternative patch (obsolete) — Splinter Review
I think we do want to set the pref, but I'm not sure.
Assignee

Updated

5 years ago
Attachment #8400892 - Flags: review?(fabrice)
Duplicate of this bug: 991262
Comment on attachment 8400892 [details] [diff] [review]
Alternative patch

Fabrice is on PTO this week.

Fernando - Can you take care of the review here?
Attachment #8400892 - Flags: review?(fabrice) → review?(ferjmoreno)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Comment on attachment 8400892 [details] [diff] [review]
Alternative patch

Carmen is more familiar than me with this code
Attachment #8400892 - Flags: review?(ferjmoreno) → review?(cjc)
Comment on attachment 8400892 [details] [diff] [review]
Alternative patch

Review of attachment 8400892 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/apps/src/OperatorApps.jsm
@@ +372,3 @@
>        }
> +
> +      return aData[key];

If the comment at https://developer.mozilla.org/en-US/docs/Mozilla/JavaScript_code_modules/Task.jsm (on the General Example, line 18) is not true anymore, can you please edit the documentation and amend it?
Attachment #8400892 - Flags: review?(cjc) → review+
This code looks good to me, but it doesn't fix all the errors introduces in OperatorApps.jsm by bug 981085. I've opened bug 992589 for that.
Assignee

Comment 10

5 years ago
(In reply to Carmen Jimenez Cabezas from comment #8)
> Comment on attachment 8400892 [details] [diff] [review]
> Alternative patch
> 
> Review of attachment 8400892 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/apps/src/OperatorApps.jsm
> @@ +372,3 @@
> >        }
> > +
> > +      return aData[key];
> 
> If the comment at
> https://developer.mozilla.org/en-US/docs/Mozilla/JavaScript_code_modules/
> Task.jsm (on the General Example, line 18) is not true anymore, can you
> please edit the documentation and amend it?

It is now half-true (because it is true for legacy generator functions). I marked bug 913115 (where the behavior changed) "dev-doc-needed".
Keywords: checkin-needed
Attachment #8400874 - Attachment is obsolete: true
https://hg.mozilla.org/integration/mozilla-inbound/rev/4f5687208984

Friendly reminder that commit messages should state what the patch is doing, not what it's fixing :)
https://developer.mozilla.org/en-US/docs/Developer_Guide/Committing_Rules_and_Responsibilities#Checkin_comment
Assignee: nobody → mar.castelluccio
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4f5687208984
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Assignee

Updated

5 years ago
Blocks: 981085
Assignee

Comment 13

5 years ago
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 981085.
User impact if declined: We can't uplift bug 981085 and so we can't enable a lot of tests on Beta.
Testing completed (on m-c, etc.): This has been an entire cycle on central.
Risk to taking this patch (and alternatives if risky): Basically no risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8400892 - Attachment is obsolete: true
Attachment #8419372 - Flags: approval-mozilla-beta?
Attachment #8419372 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1010321

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.