Last Comment Bug 991254 - [about:home] RTL + HiDPI shows the Restore Previous Session button really large
: [about:home] RTL + HiDPI shows the Restore Previous Session button really large
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Windows 8.1
-- normal (vote)
: Firefox 31
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-02 12:37 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2014-07-10 11:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard: [good first verify]
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of bug (79.20 KB, image/png)
2014-04-02 12:37 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details
Patch (1.50 KB, patch)
2014-04-02 14:17 PDT, Jared Wein [:jaws] (please needinfo? me)
mdeboer: review+
Details | Diff | Splinter Review
Patch (updated commit message) (1.48 KB, patch)
2014-04-04 07:53 PDT, Jared Wein [:jaws] (please needinfo? me)
jaws: review+
Details | Diff | Splinter Review

Description User image Jared Wein [:jaws] (please needinfo? me) 2014-04-02 12:37:25 PDT
Created attachment 8400833 [details]
Screenshot of bug

See attached screenshot. When in RTL mode, the icon should be flipped from what it looks like in LTR mode, and it also shouldn't be so huge.
Comment 1 User image Jared Wein [:jaws] (please needinfo? me) 2014-04-02 14:17:50 PDT
Created attachment 8400882 [details] [diff] [review]
Patch
Comment 2 User image Mike de Boer [:mikedeboer] 2014-04-04 06:40:31 PDT
Comment on attachment 8400882 [details] [diff] [review]
Patch

LGTM! Verified on OSX retina.
Comment 3 User image Jared Wein [:jaws] (please needinfo? me) 2014-04-04 07:53:01 PDT
Created attachment 8401888 [details] [diff] [review]
Patch (updated commit message)

Carrying forward r+ from mikedeboer, just updated the commit message.
Comment 4 User image Wes Kocher (:KWierso) 2014-04-04 16:04:36 PDT
https://hg.mozilla.org/integration/fx-team/rev/18857cdcc19c
Comment 5 User image Phil Ringnalda (:philor) 2014-04-06 09:55:18 PDT
https://hg.mozilla.org/mozilla-central/rev/18857cdcc19c

Note You need to log in before you can comment on or make changes to this bug.