Closed Bug 991406 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Passcode] Enabling or disabling the passcode lock causes a crash

Categories

(Core :: Graphics, defect, critical)

28 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 976656
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: rpribble, Unassigned)

References

Details

(Keywords: crash, reproducible, Whiteboard: [tarako-exploratory][b2g-crash], 1.3tarakorun2)

Crash Data

Attachments

(3 files, 1 obsolete file)

Attached file logcat.txt
Description:
Changing the passcode lock in any way can cause a crash (with no other apps running in the background). The crash has been observed when enabling passcode, disabling passcode, tapping back after manipulating passcode, and rapidly tapping the 'create' button after enabling a passcode.

Repro Steps:
1) Update a Tarako to BuildID: 20140402094402
2) Tap the settings icon
3) Scroll down and select Screen Lock
4) Make multiple changes to the passcode lock setting

Actual:
Making changes to the passcode lock can cause a crash.

Expected:
No crashes.

v1.3t Environmental Variables:
Device: Tarako v1.3t MOZ ril
BuildID: 20140402094402
Gaia: 578fdccea89a88b417d296f8cf20b39099d44be4
Gecko: 34ed4cbc5a59
Version: 28.1
Firmware Version: sp8810

Notes: Unable to use Firewatch debug tool. (Need a regression tag between Tarako v1.3t and Buri v1.3?)

Attachments: Video and logcat
Attached audio Settings.ogg (obsolete) —
This issue does not occur on the Buri v1.3 MOZ ril.

Environmental Variables:
Device: Buri v1.3 MOZ ril
BuildID: 20140401164001
Gaia: c5cd3a11e91339163b351d50769eaca0067da860
Gecko: 5045a67b47ed
Version: 28.0
Firmware Version: v1.2-device.cfg

No amount of passcode manipulation has produced a crash, functions as expected.

NOTE: The view may be clipped in the video, but the black bar pop-up that is visible at the bottom of the screen on the device after tapping Create on a new passcode lock is a message that 'the Settings app has just crashed'. Will attach a better video first thing in the morning.
Questions:

1. Can this be reproduced without rapid tapping?
2. Does this reproduce on 1.4?
3. Can you include a dmesg log?
Keywords: qawanted
Not able to reproduce the issue in latest Buri 1.4

Attempted to repro by navigating to the Create Passcode screen then entering a new code rapidly, entering a new code slowly, tapping "Create" rapidly and slowly, and navigating in between various screens within the "Screen Lock" UI. 

Environmental Variables: 
Device: buri 1.4 MOZ
BuildID: 20140404000202
Gaia: b4f3b84ec68233a99fd5865c15cfe28aebe26531
Gecko: 3186bbc50050
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: ddixon
Attached file CrashDesmg.txt
Attached audio CrashVideo.ogg
Adding video with better visibility recorded 4/4/14.
Attachment #8401011 - Attachment is obsolete: true
Can you include a crash report URL?
Keywords: qawanted
Severity: normal → critical
blocking-b2g: --- → 1.3T?
Component: Gaia::Settings → General
Keywords: crash, reproducible
Whiteboard: [tarako-exploratory] → [tarako-exploratory][b2g-crash]
I'm sorry, I'm unable to attach a crash report URL due to bug 990300.
Keywords: qawanted
Naoki - Is there a way to get the crash dump here?
Flags: needinfo?(nhirata.bugzilla)
https://crash-stats.mozilla.com/report/index/9727fa1e-0fd2-41c2-9dd0-6680d2140404

Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0xe464 	
1 	ashmem (deleted) 	ashmem (deleted)@0xddb2 	
2 	ashmem (deleted) 	ashmem (deleted)@0xdd7e 	
3 	libxul.so 	mozilla::gfx::DrawTargetCairo::CreateSourceSurfaceFromNativeSurface(mozilla::gfx::NativeSurface const&) const 	gfx/2d/DrawTargetCairo.cpp
Crash Signature: [@ mozilla::gfx::DrawTargetCairo::CreateSourceSurfaceFromNativeSurface(mozilla::gfx::NativeSurface const&) const ]
Flags: needinfo?(nhirata.bugzilla)
It looks like the engineering build might be the way to go when we get this.
You would have to su or adb root before trying to get the crash report.
Component: General → Graphics
Product: Firefox OS → Core
Version: unspecified → 28 Branch
does it only crash when one tries to break it?
i wonder what's the reproduce rate and if you don't try to break it, can user chagne the passcode? thanks
Flags: needinfo?(rpribble)
(In reply to Joe Cheng [:jcheng] from comment #11)
> does it only crash when one tries to break it?
> i wonder what's the reproduce rate and if you don't try to break it, can
> user chagne the passcode? thanks

This is consistently reproducible crash present only on Tarako. We don't ship with crashes that are on a blatantly obvious in a user flow. It wouldn't even matter if a special workaround could be done here to get the passcode changed - we have a MTBF that we have to meet to ship the product. This is an obvious blocker.
Flags: needinfo?(rpribble)
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976656
Whiteboard: [tarako-exploratory][b2g-crash] → [tarako-exploratory][b2g-crash], 1.3tarakorun2
QA Contact: ddixon
You need to log in before you can comment on or make changes to this bug.