Closed Bug 991550 Opened 6 years ago Closed 6 years ago

[Tarako][Music]Switch between Music and Songs categories get crash

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 970007
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: mlien, Unassigned)

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Attachments

(2 files, 2 obsolete files)

Attached file crash dump
[Device]
  Tarako
---------------------------------------------
[Reproduction build] - V1.3T
  Gaia      c418ec10d1e1d53c6757ad12b2320c204808d251
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/36b1279ef6df
  BuildID   20140402164000
  Version   28.1
---------------------------------------------
[Reproduce Steps]
  1. Launch Music app
  2. Switch to Songs category
  3. Switch back to Music category
---------------------------------------------
[Expected Result]
  Switch normally
---------------------------------------------
[Actual Result]
  app crash
blocking-b2g: --- → 1.3T?
i wonder how easy it is to reproduce this? Thanks
Flags: needinfo?(mlien)
in my environment, reproduce rate is 100%
Flags: needinfo?(mlien)
1.3T+ as this is breaking a common use case
ni? Dkuo, can you please look at it? thanks
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(dkuo)
hi Tim, dkuo should focus on the other tarako music bug, is there anyone that can take a look? Thanks
Flags: needinfo?(timdream)
(In reply to Joe Cheng [:jcheng] from comment #4)
> hi Tim, dkuo should focus on the other tarako music bug, is there anyone
> that can take a look? Thanks

There isn't anyone left in Taipei for that. We need help from the media team. Or, if Dominic can navigate his peer on diagnosing it would be great too.
Flags: needinfo?(timdream)
Hi Hema and David, could you find someone to help out on this bug please?  I've been able to reproduce this crasher.
Flags: needinfo?(hkoka)
Flags: needinfo?(dflanagan)
If this is a Tarako-specific gecko crash we may not have anyone on the media team who can do anything about it and who also has a Tarako device.
Flags: needinfo?(dflanagan)
Jim can help with investigation but not sure if he will be able to fix anything. 

I have asked Bhavana to ship Tarako to him on priority mail. Can you send it out please

Thanks
Hema
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(hkoka)
Flags: needinfo?(bbajaj)
If this only happen on tarako then I am probably the best guy to investigate this, cause I think Jim doesn't have a tarako yet, and I just wrapped up the big patch and set the review to Jim, he should be reviewing it.

Roughly looking I think this should be a gecko issue because I couldn't reproduce on my tarako, taking it first and if I have go back to the reviewing 1.3t blocker, I will un-assign myself and find someone for help.
Assignee: nobody → dkuo
Flags: needinfo?(dkuo)
Assuming I get a Tarako, I have no problems taking a look at this.
Flags: needinfo?(squibblyflabbetydoo)
verify again with today's build, it's still crash

Gaia      9afe8145b5d309bdf2ef196b559e6dfd997faeeb
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/c2a0ee7b4d58
BuildID   20140407164002
Version   28.1
(In reply to Jim Porter (:squib) from comment #10)
> Assuming I get a Tarako, I have no problems taking a look at this.

You should be receiving a tarako today -- one got shipped to you on priority
(In reply to Hema Koka [:hema] from comment #12)
> (In reply to Jim Porter (:squib) from comment #10)
> > Assuming I get a Tarako, I have no problems taking a look at this.
> 
> You should be receiving a tarako today -- one got shipped to you on priority

I did, but they didn't ring my doorbell, so now I have to wait until tomorrow, or see if I can pick it up somewhere...
Before I flashed today's pvt build, I found I was unable to reproduce this issue on my tarako(with the build from intranet), then I turned to flash the pvt build today, it become easy to reproduce it.

I didn't notice anything different until I found the APZ was disabled on the pvt build, the intranet build was APZ enabled, so probably APZ for app is related.
Mike, since this is a crash bug, would you please provide the minidump instead of the raw dump? that can help devs to investigate this issue, thanks.
Flags: needinfo?(mlien)
Attached file dmp.txt (obsolete) —
minidump parsed from 1st attachment
Flags: needinfo?(mlien)
Attached file dmp_update.txt (obsolete) —
Attachment #8404573 - Attachment is obsolete: true
Attached file dmp_build0409.txt
update the latest build's minidump result
Attachment #8404575 - Attachment is obsolete: true
dkuo, is this a dup of bug 970007?
Flags: needinfo?(dkuo)
Clearing the NI, I had shipped a Tarako to Jim, he should have received it.
Flags: needinfo?(bbajaj)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #19)
> dkuo, is this a dup of bug 970007?

Actually I don't know and I am not familiar with the minidump which Mike attached(attachment 8404594 [details]). Joe, can you please find someone from the device team to investigate this? I believe anyone from the gecko side can do this better and faster than me, so unassigning myself, thanks.
Assignee: dkuo → nobody
Flags: needinfo?(dkuo) → needinfo?(jcheng)
Ni? Peter, is this similar to the other graphics bug you are looking at? thanks
Flags: needinfo?(jcheng) → needinfo?(pchang)
(In reply to Joe Cheng [:jcheng] from comment #22)
> Ni? Peter, is this similar to the other graphics bug you are looking at?
> thanks
Yes, I think ht is a dup of bug 970007.

You can see the following stack from attachment 8404594 [details]. 
 1  libxul.so!BufferUnrotate(unsigned char*, int, int, int, int, int) [BufferUnrotate.cpp:bdf9a55b4553 : 35 + 0xb]
     sp = 0xbed07fc8    pc = 0x40abe5cb
    Found by: stack scanning
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(pchang)
Resolution: --- → DUPLICATE
Duplicate of bug: 970007
Thanks Peter!
You need to log in before you can comment on or make changes to this bug.