Closed Bug 991577 Opened 6 years ago Closed 6 years ago

[Tarako][MMS][CardView] A white screen shows up after tapping on SMS card in cardview instead of resuming SMS app.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 935750
blocking-b2g -
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: bli, Unassigned)

Details

(Whiteboard: OOM [sprd295140])

Attachments

(1 file)

Environment:
---------------------------------------------------
Gaia      c418ec10d1e1d53c6757ad12b2320c204808d251
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/36b1279ef6df
BuildID   20140402164000
Version   28.1
ro.build.version.incremental=eng.cltbld.20140402.202437
ro.build.date=Wed Apr  2 20:24:44 EDT 2014


Steps to reproduce:
---------------------------------------------------
1. Send multiple mms to the test device using the same number.
   (e.g. Send 3 mms to the test device - one is attached with a jpg file, one is attached with an amr file, and the last one is attached with a 3gp file.)

2. Launch SMS, and open the message thread.

3. Save the attachments

4. View the attachments(e.g view pictures, and play the music and videos)

5. Repeat step 3 and 4 for several times

6. Long press 'Home' button
   --> Cardview shows up

7. Tap on the SMS card in cardview


Actual result:
---------------------------------------
A white screen shows up. Cannot resume SMS app.


Expected result:
---------------------------------------
Resume SMS app.


Additional info:
---------------------------------------
This cannot be reproduced 100%. 
Pls try more times.
blocking-b2g: --- → 1.3T?
from the steps, it seems like you have to intentionally trying to break it, not blocking tarako release.
blocking-b2g: 1.3T? → -
This is a dup bug.  Bug 983772, I did it with the Music app.  You can do it with any app.
Whiteboard: OOM
Oh sorry.  Actually it's not quite a dup.
Bingqing - Can you try reducing the STR here?
Flags: needinfo?(bli)
(In reply to Jason Smith [:jsmith] from comment #4)
> Bingqing - Can you try reducing the STR here?

i.e. try to find the minimal STR to use here to reproduce the bug
This issue is hard to reproduce. I try to minimal reproduced steps. My steps are as following.

1. Launch SMS via app icon in homescreen
2. Press home button go back to homescreen
3. Repeat steps 1~2 several time(might be more than 10?)

Sometimes, you will see a white screen while launching SMS app. I attach dmesg log for reference. But I don't attach console log. Because I don't see some useful message in console log.
(In reply to Ian Liu [:ianliu] from comment #6)
> Created attachment 8405160 [details]
> dmesg_white_screen_blocking_while_launching_SMS.txt
> 
> This issue is hard to reproduce. I try to minimal reproduced steps. My steps
> are as following.
> 
> 1. Launch SMS via app icon in homescreen
> 2. Press home button go back to homescreen
> 3. Repeat steps 1~2 several time(might be more than 10?)
> 
> Sometimes, you will see a white screen while launching SMS app. I attach
> dmesg log for reference. But I don't attach console log. Because I don't see
> some useful message in console log.

If you can reproduce it as my steps, try to long press home button for viewing recent apps. Tap on the SMS card in card view. Then, you can see the actual result.

Actual result:
---------------------------------------
A white screen shows up. Cannot resume SMS app.

Build version:
Gaia      27a0e773e01eed74e20709bdcab6894469f42a72
Gecko     f6893b30657b8b8208a5c9de8b6b96b9a09a3fb1
BuildID   20140410042058
Version   28.1
ro.build.version.incremental=250
ro.build.date=Thu Apr 10 04:16:35 CST 2014

Build: sp6821a_gonk-userdebug 4.0.4.0.4.0.4 OPENMASTER 250 test-keys
FTR I think I saw this on a Peak 1.3 too, from time to time, but no absolute STR.
I try to use the same steps as comment 6 with Contact app. And I got a black screen while I'm able to reproduce. Shall I suspect that an app is launching/re-launch while it just be killed in the same time? 

The same symptom is that:
1. The app is not able to launch in recent app. It should be killed I think.
2. Launch the app from home screen. It looks like re-launch.
This bug can be easily reproduced on build with the steps that Ian mentioned in comment #6.

> 1. Launch SMS via app icon in homescreen
> 2. Press home button go back to homescreen
> 3. Repeat steps 1~2 several time(might be more than 10?)

Build Info:
---------------------------------------------------
Gaia      bbba09c732c35d9434ecb04d5e2e41d05511f4d9
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/65b4c58a7da9
BuildID   20140410164004
Version   28.1
ro.build.version.incremental=eng.cltbld.20140410.210129
ro.build.date=Thu Apr 10 21:01:38 EDT 2014
Flags: needinfo?(bli)
(In reply to Bingqing Li from comment #10)
> This bug can be easily reproduced on build with the steps that Ian mentioned
This bug can be easily reproduced on build 20140410164004.
Can we include a reproduction rate using comment 10's STR?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #12)
> Can we include a reproduction rate using comment 10's STR?

Along with knowledge of how many launches of the SMS app it took to reproduce the bug in each case.
Able to reproduce using STR in comment 10 on todays 1.3 Tarako PVT build. It is, however, a very low reproduction rate. 

Repro Rate: 1/30, 3%

I got a slightly higher Repro rate using these STR:

1) Launch SMS app via icon on homescreen
2) Open existing MMS message thread
3) Press home button to return to homescreen
4) Select SMS icon to reopen SMS app
[Repeat Steps 3-4]

Repro rate: 1/20, 5%


Attempted reproducing both STR's with 2 existing MMS threads.

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140414004001
Gaia: 0e7f21e61625b75a9149480cd5a259211549f020
Gecko: 3b02811c314a
Version: 28.1
Firmware Version: sp6821a
Keywords: qawanted
If you consume too much memory in message app(e.g.  loading the huge thread), app is possible to be killed while switching to background(launching cardview will also push the app to backgroung) because of oom issue. Maybe this white screen issue happens when we are trying to launch an app which should be killed but action is not completed yet. ni? Alive for the possibility of this guessing and how we could avoid this in 1.3 window manager.
Flags: needinfo?(alive)
Bug 935750 fixed this issue in master branch.
For v1.3 I think we could:
1. remove the card when cardsview.js got appterminated event.
2. Close cardview or shift to next card.
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!][God bless Taiwan.] from comment #16)
> Bug 935750 fixed this issue in master branch.
> For v1.3 I think we could:
> 1. remove the card when cardsview.js got appterminated event.
> 2. Close cardview or shift to next card.

Can we cherry-pick this patch from v1.4?
blocking-b2g: - → 1.3T?
(In reply to James Zhang from comment #17)
> (In reply to Alive Kuo [:alive][NEEDINFO!][God bless Taiwan.] from comment
> #16)
> > Bug 935750 fixed this issue in master branch.
> > For v1.3 I think we could:
> > 1. remove the card when cardsview.js got appterminated event.
> > 2. Close cardview or shift to next card.
> 
> Can we cherry-pick this patch from v1.4?

Idon't think the work is trivial to pick the patch back to 1.3T. Hi Alive, could you confirm it. Thanks!
Flags: needinfo?(alive)
Yap, this is a non-trivial feature request to me. I recommend not blocking on this bug.
Flags: needinfo?(alive)
given its not trivial here and since a decision was made earlier on this not being a blocker, minusing it.
blocking-b2g: 1.3T? → -
Whiteboard: OOM → OOM [sprd295140]
Duplicate of this bug: 1000703
If this is fixed on master, like alive said in comment 16, shouldn't we close this bug or dupe it to bug 935750 ?
Flags: needinfo?(alive)
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: suspending-app
Blocks: 995119
No longer blocks: 995119
You need to log in before you can comment on or make changes to this bug.