Memory leak of 104 bytes from 1 block allocated in NS_NewLocalFile

VERIFIED DUPLICATE of bug 99115

Status

VERIFIED DUPLICATE of bug 99115
17 years ago
10 years ago

People

(Reporter: stephend, Assigned: bugzilla)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

Memory leak of 104 bytes from 1 block allocated in NS_NewLocalFile
        Distribution of leaked blocks
               104 bytes from 1 block of 104 bytes (0x0eda1f78) 
        Allocation location
            new(UINT)+0xc        [new.cpp:23 ip=0x002da05c]
            NS_NewLocalFile+0x31
[c:\moz_src\mozilla\xpcom\io\nsLocalFileWin.cpp:2042 ip=0x100c7211]
            nsStdURL::GetFile(nsIFile * *)+0x741
[c:\moz_src\mozilla\netwerk\base\src\nsStdURL.cpp:1210 ip=0x04f71021]
            nsFileChannel::Init(int,int,nsIURI *)+0x1d8
[c:\moz_src\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp:78 ip=0x05060988]
            nsFileProtocolHandler::NewChannel(nsIURI *,nsIChannel * *)+0x8f
[c:\moz_src\mozilla\netwerk\protocol\file\src\nsFileProtocolHandler.cpp:138
ip=0x05065d41]
            nsIOService::NewChannelFromURI(nsIURI *,nsIChannel * *)+0xab6
[c:\moz_src\mozilla\netwerk\base\src\nsIOService.cpp:751 ip=0x04f810a6]
            NS_OpenURI(nsIChannel * *,nsIURI *,nsIIOService *,nsILoadGroup
*,nsIInterfaceRequestor *,UINT)+0x16d [.\..\..\..\dist\include\nsNetUtil.h:134
ip=0x091e84f5]
            nsURLFetcher::FireURLRequest(nsIURI *,nsILocalFile
*,nsIFileOutputStream *,(*)(UINT,char const*,char const*,int,WORD const*,void
*),void *)+0x58b [c:\moz_src\mozilla\mailnews\compose\src\nsURLFetcher.cpp:360
ip=0x091e811b]
            nsMsgAttachmentHandler::SnarfAttachment(nsMsgCompFields *)+0x12d7
[c:\moz_src\mozilla\mailnews\compose\src\nsMsgAttachmentHandler.cpp:907
ip=0x09216fa7]
            nsMsgComposeAndSend::GatherMimeAttachments(void)+0x1942
[c:\moz_src\mozilla\mailnews\compose\src\nsMsgSend.cpp:629 ip=0x0919ec52]
Doug, might this be yours?  
Keywords: mlk
changing qa over to myself.
QA Contact: sheelar → stephend

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 99115 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
nice, I filed a dup of a bug I filed already...sigh.

verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.