Closed Bug 991896 Opened 7 years ago Closed 7 years ago

[B2G][Calendar] Unable to setup an online account in Calendar

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected)

RESOLVED FIXED
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: jschmitt, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Somethingwrong.png
Description:
User is displayed with the message "Something went wrong" when trying to setup an online Calendar account.

Repro Steps:
1) Updated Buri to BuildID: 20140403040201
2) Connect to Wifi/Internet
3) Select the drawer icon
4) Select the + icon
5) Select Google, sign in and select accept

Actual:
Unable to setup an online Calendar account.

Expected:
The user can add an account to the Calendar.

Environmental Variables:
Device: Buri 1.5 MOZ
BuildID: 20140403040201
Gaia: 0e974ff33ba47f3d1e59df1e0ad534f1bbe3ef8a
Gecko: 91be2828f17e
Version: 31.0a1
Firmware Version: V1.2-device.cfg 

Notes:

Repro frequency: 100%
See attached: Screenshot
Does this happen on 1.4?
blocking-b2g: --- → 1.5?
Keywords: qawanted, regression
(In reply to Jason Smith [:jsmith] from comment #1)
> Does this happen on 1.4?

No this does not. Calendar correctly syncs with a google account without issue.

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140403000210
Gaia: e0186439b9c2c03acd78e9ae011a0071865e7ffb
Gecko: 5bccd264a0e3
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: ckreinbring
Regression window:

No repro
Build ID: 20140331234632
Gecko: https://hg.mozilla.org/integration/b2g-inbound/rev/b208122a322e
Gaia: 7e8fa687f5a383740619517dba17174669a34164
Platform Version: 31.0a1
Firmware Version: V1.2-device.cfg

Repro
Build ID: 20140401011837
Gecko: https://hg.mozilla.org/integration/b2g-inbound/rev/ed36edca95ba
Gaia: 3c23b5013e62d6f059d9a0b9f9e8c8db0c3aa2fe
Platform Version: 31.0a1
Firmware Version: V1.2-device.cfg

Old Gaia / New Gecko - OK
New Gaia / Old Gecko - Fail
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/7e8fa687f5a383740619517dba17174669a34164...3c23b5013e62d6f059d9a0b9f9e8c8db0c3aa2fe
Looks to be caused by bug 984572.
Blocks: 984572
Fixed by backing out the offending patch: https://github.com/mozilla-b2g/gaia/commit/92d4447a9ee72a49a09410143c9cb3068f73cd53
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 1.5? → ---
You need to log in before you can comment on or make changes to this bug.