Closed Bug 991909 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Bluetooth] There is no notification on the receiving device if the sending device cancels a file transfer via bluetooth

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 868303
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: demerick, Unassigned)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file logcat.txt
Description:
There is no notification on the FFOS device if the sending device cancels a file transfer via bluetooth.

Repro Steps:
1) Update a Tarako to BuildID: 20140403004001
2) Pair a Tarako or Buri (device under test) with another device via bluetooth
3) Other device: Send a file to the DUT
4) DUT: View the notification 'Accept Bluetooth file transfer?'
5) Other device: Cancel the file transfer
6) DUT: Tap 'Transfer' on the 'Accept Bluetooth file transfer?' notification

Actual:
The notification disappears, but the transfer does not start and there is no notification that the transfer was cancelled by the sending device.

Expected:
The user should be informed that the file transfer was cancelled.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140403004001
Gaia: 8d212f640014db62c622e8c939ddbf8595f00438
Gecko: ddd7ba612cfe
Version: 28.1
Firmware Version: sp8810

Repro frequency: 100%
See attached: screenshot, logcat.txt
Attached image bt_file_noMsg.png
This issue reproduces on the Buri 1.3 MOZ RIL

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: v1.2-device.cfg

The user was not informed when the sending device cancelled the bluetooth file transfer.
This is a known issue that we track it via bug 868303.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868303
You need to log in before you can comment on or make changes to this bug.