hekticmedia.com - JavaScript menu navigation only works on NS 4.+

RESOLVED WONTFIX

Status

Tech Evangelism
Desktop
P3
normal
RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: Dac Chartrand, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [layers], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010909
BuildID:    2001090908

The JavaScript menu navigation only works for NS 4.+ , it also works for IE 4+
but does not work for Moz or NS 6+ ... 

Reproducible: Always
Steps to Reproduce:
1. go to webpage
2. navigate nowhere using javaScript:jumpTo(someInt)
3. Try with other web browser, works fine.

Actual Results:  Navigation fails.

Expected Results:  Navigation functional.

Comment 1

17 years ago
Clicking on "Sell" works for me on 2001091003 Win2k. (It opens a new browser
window.)

Comment 2

17 years ago
Confirmed with build 2001092308, Win NT

Comment 3

17 years ago
This is related to layers, and I'm unsure of the level of layer support.  Pasted
here is the relevant code that isn't working.

showme="show"
tlayer = ("layer"+id)
nlayer = ("layer"+idtemp)
document.layers[tlayer].visibility= (hideme)
document.layers[nlayer].visibility= (showme)

id is the current layer, and idtemp is the input to jumpTo().  (also note the
lack of semicolons)

Although I'm no expert, I believe this is not the browser's fault, and am
suggesting this be moved to evangelism.

Comment 4

17 years ago
Confirming as Tech Evangelism.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: JavaScript menu navigation only works on NS 4.+ → hekticmedia.com - JavaScript menu navigation only works on NS 4.+

Updated

17 years ago
Blocks: 113492

Comment 5

17 years ago
ecomm
Assignee: bclary → aruner
Component: US General → US Ecommerce
QA Contact: zach → bclary

Updated

17 years ago
No longer blocks: 113492
OS: Windows 98 → All
Priority: -- → P3
Hardware: PC → All
Whiteboard: [layers]

Comment 6

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 7

8 years ago
Funny, after 9 years this bugged site is still here.

Comment 8

4 years ago
smiling at the "Please Be Patient While The Website Is Loading (70k)".
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.