Closed Bug 992538 Opened 6 years ago Closed 6 years ago

Firefox should not try to connect to non-address entries in Location bar

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1080682

People

(Reporter: aljullu, Unassigned)

Details

Firefox should be clever enough to differentiate URLs from strings that have a similar structure but are not URLs.

For example, if the users inputs these entries in the location bar:

24/3
Error: line 45
window.myVar

It is evident that they are not URLs, however, Firefox tries to connect to those address instead of searching them on the search engine defined by the user.

Google Chrome handles this properly.
So bug 494092 took care of 42/42.
I've not seen "Error: line 45" not work because it has a bunch of spaces - it certainly seems to work on Firefox 34.
"window.myVar" is bug 1080682.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080682
You need to log in before you can comment on or make changes to this bug.