Closed Bug 992569 Opened 6 years ago Closed 2 months ago

Toolkit's password prompts should have product name in the window title

Categories

(Toolkit :: General, defect, minor)

28 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: bege10, Assigned: KaiE)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [good first bug] [passwords:master-password])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

For entering the general password in Firefox there is a window with the title "Passwort erforderlich" (in German, English translation: Password necessary).
This window title is exactly the same as in Thunderbird.
To make auto-type of password managers more usable, please, add "Firefox" to the window title.
Severity: normal → minor
Component: Untriaged → General
Product: Firefox → Toolkit
Duplicate of this bug: 992570
Sorry, I would like to withdraw previously said, maybe it can bring some help.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Windows title for general password entry → Add product name to the "Password Required" window title
I support this bug report. We have a window poping up from anywhere, we don't know if it is from the OS (which has background tasks checking for updates etc) or from firefox, so we don't know which password to enter. The window should mention explicitely the Firefox master password.
(french interface for me).

Also, how difficult is it to set up a nasty web page that opens a popup that is identical to the firefox one, to capture user passwords?
I'd rather type my master password in the main window of Firefox. But that would be a different bug I guess.
Please, this is definitely little effort to accomplish and big help for users.
Thank you very much.
Whiteboard: [good first bug]
Hi,
I want to work on this. What exactly should I change the content into?
(In reply to Nikhil Gupta from comment #6)
> Hi,
> I want to work on this. What exactly should I change the content into?

https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide

https://dxr.mozilla.org/mozilla-central/search?q=PromptPassword2
Add a like the https://dxr.mozilla.org/mozilla-central/search?q=GetStringFromName%28%22brandShortName%22%29%3B


Hmmm, actually I have a patch for it once, but I'm not sure it is better for product, so I didn't submit it.
Attached patch bug992569 v1.diff (obsolete) — Splinter Review
For reference, it may require some changes to adapt to the current base.
The platform is set to Windows, but I am pretty sure it's the same on Mac. Should this be set to all?
OS: Windows 7 → All
Hardware: x86_64 → All
Blocks: 674483
Whiteboard: [good first bug] → [good first bug] [passwords:master-password]
Hello, Is this bug currently being worked on by someone? 
If not can i work on this?
Hi there,
so I've decided to try my luck with this one as my first bug, and I've already got a working build :)

Here is the code I use:
```
const BRANDING_BUNDLE_URI = "chrome://branding/locale/brand.properties";
var brandShortName = Services.strings.
                       createBundle(BRANDING_BUNDLE_URI).
                       GetStringFromName("brandShortName");
```

If anyone can help me how to continue I would be grateful, else I will try to dig through the documentation to find out the next step myself. Also any kind of feedback is appreciated.

How can this move forward? There is already a patch provided and this seems like a simple fix. What is blocking?

Summary: Add product name to the "Password Required" window title → Toolkit's password prompts should have product name in the window title
Comment on attachment 8716911 [details] [diff] [review]
bug992569 v1.diff

>-PromptUsernameAndPassword2=Authentication Required
>-PromptPassword2=Password Required
>+# LOCALIZATION NOTE - %S is brandShortName
>+PromptUsernameAndPassword2=%S Authentication Required
>+# LOCALIZATION NOTE - %S is brandShortName
>+PromptPassword3=%S Password Required

You forgot to change 2 to 3 in PromptUsernameAndPassword2
Attachment #8716911 - Flags: review-
Comment on attachment 8716911 [details] [diff] [review]
bug992569 v1.diff

Surrounding code has changed. Marking obsolete.

Other windows seems to show the title as
  information - product name

I'll submit a phabricator patch.
Attachment #8716911 - Attachment is obsolete: true
Assignee: nobody → kaie
Status: NEW → ASSIGNED

kmag, mconley: For users who have a master password set, they will get a small, separate prompt for the master password. This enhancement is suggested to make it more obvious into which application they'll enter it.

Duplicate of this bug: 1612398
Pushed by kaie@kuix.de:
https://hg.mozilla.org/integration/autoland/rev/5dd2196d74f9
Toolkit's password prompts should have product name in the window title. r=MattN
Attachment #9123161 - Attachment description: Bug 992569 - Toolkit's password prompts should have product name in the window title. r?mconley → Bug 992569 - Toolkit's password prompts should have product name in the window title. r?MattN
Pushed by kaie@kuix.de:
https://hg.mozilla.org/integration/autoland/rev/0f039e58254b
Toolkit's password prompts should have product name in the window title. r=MattN

The test failures were caused by tests that look for an exact match of the Window title. Which no longer was working, because we changed the window title. The updated commit fixes the tests.

Flags: needinfo?(kaie)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

The merge to m-c will resolve the bug with appropriate flags. We don’t resolve on autoland.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla74 → ---
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Thank you very much for fixing :-)

You need to log in before you can comment on or make changes to this bug.