Add a right click copy as JSON to request parameters in network devtools

RESOLVED DUPLICATE of bug 859058

Status

enhancement
RESOLVED DUPLICATE of bug 859058
5 years ago
10 months ago

People

(Reporter: xwraithanx, Unassigned)

Tracking

28 Branch
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

1) Open devtools to network tab
2) Do a POST request or some other request with params
3) Click the POST request
4) Click the Params tab in the right side
5) Right click in the params


Actual results:

I got a standard context menu


Expected results:

I would love if it had an option for copying the params as URL or JSON encoded so you can redo the request from the commandline when debugging API endpoints.
(Reporter)

Updated

5 years ago
Component: Untriaged → Developer Tools: Netmonitor

Updated

5 years ago
Severity: normal → enhancement
Would copy as HAR do the trick?
Feel free to reopen if not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859058

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.