MJPG stream crashes Mozilla while loading another URL

VERIFIED DUPLICATE of bug 100595

Status

()

Core
ImageLib
--
critical
VERIFIED DUPLICATE of bug 100595
17 years ago
4 years ago

People

(Reporter: Olivier Cahagne, Assigned: Stuart Parmenter)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build ID: 2001091003 on Win2k.
URL: http://dormcam.mine.nu:8080/index1.shtml

Steps to reproduce:
1. load http://dormcam.mine.nu:8080/index1.shtml
leave it here, displaying a mjpg stream of images.
2. After 5 minutes, open a new window with URL http://imp.free.fr/ for example
(but any other simple page will do the trick) and watch Mozilla crashing.

Expected result: not crashing.

Talkback IDs: TB35234587E and TB35234769M. I'm submitting two of them, produced
with 2 different sites loaded for Step 2 above. I hope there're the same.

This is actually based on bug 42224 but I saw it crashing for me so I submit a
new bug report after chatting about that on #mozillazine. I must note another
Axis-powered Web site also crashes for me (http://sv-cam.epita.fr/ restricted,
if you need login, please feel free to ask here) and the Talkback ID is TB35234225X.
CC Stephend my personal talkback bot :-)
The 2 stack trace IDs you posted are indeed the same traces.
(Reporter)

Comment 4

17 years ago
Thanks, so it's indeed linked to this MJPG stream.
Looking at the trace, ImageLib might not be the right component to choose for
this bug, any idea of a better component choice ?

Comment 5

17 years ago
networking? http?

Comment 6

17 years ago
(repeating my comment from bug 42224 [sorry to sound like a cracked record, but
this seems further evidence that these server push problems maybe something to
do with HTTP is someway.  I'm no expert so I appologise if I'm off track])

"This may be a long shot, but could it have anything to do with bug 97683?  It
seems that somewhere along the line the http connection is [getting] corrupted
([and] mozilla losing track of it?)?"
(Reporter)

Comment 7

17 years ago
Reproducible testcase (using build 2001112111 on Linux):

1. Load URL http://dormcam.mine.nu:2057/cgi-bin/video ,
2. See it failing after a few seconds.

Sniffing doesn't shows the mjpg image then a "--Weird" and transmission ends here.
There's a serie of TCP PSH/ACK, then Mozilla sends a TCP packet with FIN flag
set, why ?
(NS4.79 does the same btw).
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 100595 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup, based on stack.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.