Closed Bug 992635 Opened 7 years ago Closed 7 years ago

Flexbox does not work correctly when applied to a <button>

Categories

(Core :: CSS Parsing and Computation, defect)

28 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 984869

People

(Reporter: daniel, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

I've applied the same css to a <div> and a <button> (including some other properties that should nullify most of button's visual behaviors.
http://jsfiddle.net/Vgh37/


Actual results:

Flexbox doesn't apply correctly to the contents within the <button>.


Expected results:

The flexbox styles should properly apply to the contents of the <button> just like they do to the <div>, laying them out horizontally and changing their order.
CSS as a first approximation.
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 984869
You need to log in before you can comment on or make changes to this bug.