Closed Bug 992747 Opened 6 years ago Closed 6 years ago

"View">"Toolbars">"My toolbar" toggle not working for non-customizable toolbars

Categories

(Firefox :: Toolbars and Customization, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: arun.emmafan, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3-])

Attachments

(2 files)

Attached file google.xpi
The toolbar toggle is not working in Firefox 29.
The menu item is added in firefox menu for my own add on.
"View">"Toolbars">"Own toolbar".  But clicking this item does not toggle my toolbar.
I have attached my sample toolbar.
As a workaround, make the toolbar customizable...
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Summary: "View">"Toolbars">"My toolbar" toggle not working in FF 29. → "View">"Toolbars">"My toolbar" toggle not working for non-customizable toolbars
Whiteboard: [Australis:P3-]
Blocks: 985815
OS: Mac OS X → All
Hardware: x86 → All
Attachment #8403679 - Flags: review?(jaws) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/67e72ea05f66
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/67e72ea05f66
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8403679 [details] [diff] [review]
toolbar visibility setting doesn't work for non-customizable toolbars,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: non-functioning items in toolbar context menus and other places where toolbar visibility can be toggled
Testing completed (on m-c, etc.): on m-c, has automated test
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8403679 - Flags: approval-mozilla-beta?
Attachment #8403679 - Flags: approval-mozilla-aurora?
Attachment #8403679 - Flags: approval-mozilla-beta?
Attachment #8403679 - Flags: approval-mozilla-beta+
Attachment #8403679 - Flags: approval-mozilla-aurora?
Attachment #8403679 - Flags: approval-mozilla-aurora+
Hi,
Suppose i hidden my toolbar programmatically  using below code .
 var toolbarObject = win.document.getElementById("my-toolbar-ID");
 if(toolbarObject!=null && ("undefined" != typeof (toolbarObject)))
{
				toolbarObject.setAttribute("collapsed", true);
}

Then toolbar hidden from browser but its not persistent for successive launch of browser. If i re-opened or opened new window then the toolbar is displayed on browser. 
I wanted the toolbar is hidden until that toolbar is displayed  from the option  "View">"Toolbars">"Own toolbar".


But if toolbar toggled from the  option "View">"Toolbars">"Own toolbar" then the behavior stored persistently and toolbar status is  same for successive launch of browser.

Please help me how to programmatically toggle my own toolbar persistently?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Please don't ever reopen closed bugs to ask for help programming your add-on.

You can get help by posting to mozilla.dev.extensions: https://groups.google.com/forum/#!forum/mozilla.dev.extensions // https://lists.mozilla.org/listinfo/dev-extensions
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.