Closed Bug 992985 Opened 8 years ago Closed 8 years ago

Regression: Scrollerable layers yields flickering in animated GIFs

Categories

(Firefox for Android Graveyard :: General, defect)

30 Branch
ARM
Android
defect
Not set
normal

Tracking

(fennec30+)

RESOLVED DUPLICATE of bug 992218
Tracking Status
fennec 30+ ---

People

(Reporter: ibarlow, Assigned: cwiiis)

References

Details

(Keywords: regression, reproducible)

I've been seeing a lot of weird flickering and artifacting when I open animated gifs in Nightly. 

STR
- Open a gif, like http://replygif.net/i/1487.gif
- Expect gif to play
- Actual: gif plays, but there is lots of flickering around the image. 

From what I hear from kids these days, animated gifs are kind of a thing, so we should make sure we're displaying them properly.
Probably a regression from recent graphic refactoring work.
tracking-fennec: --- → ?
I found the same regression range as Bug 992218.
1.mozilla central:
good build: 08-03-2014 
bad build: 09-03-2014
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d01bf8596d3b&tochange=21f293fc8d34

2.inbound:
good build: 1394227648
bad build: 1394229086
pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c8355055899c&tochange=40b2ac413772
Assignee: nobody → chrislord.net
tracking-fennec: ? → 30+
Blocks: b2g-tiling
Flags: needinfo?(bas)
Summary: Flickering on animated gifs → Regression: Scrollerable layers yields flickering in animated GIFs
I think we can treat this as a duplicate of bug 992218.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 992218
Flags: needinfo?(bas)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.