Closed Bug 993018 Opened 6 years ago Closed 6 years ago

Make the "place new call" feature independent of the callscreen->appwindow message channel

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: etienne, Assigned: etienne)

References

Details

Attachments

(2 files)

Other blocking point for bug 990003.
1.3t? because blocking a 1.3t+
Assignee: nobody → etienne
Blocks: 990003
blocking-b2g: --- → 1.3T?
Attached file Gaia PR
Same deal.
Sorry for the emergency, trying to sweeten the deal with more test coverage :)
Attachment #8402784 - Flags: review?(anthony)
triage: 1.3T+ for resolving dialer incoming call performance
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [tarako_only]
This will land on master...
Whiteboard: [tarako_only]
Comment on attachment 8402784 [details] [review]
Gaia PR

That actually makes more sense to me.
Attachment #8402784 - Flags: review?(anthony) → review+
https://github.com/etiennesegonzac/gaia/commit/5c78a28ca1fac2b9088ee17a6aec7eddfff029ac
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
There are a lot of conflicts when cherry-pick this into v1.3t branch?
Can you please rebase your patch on v1.3t?
Flags: needinfo?(etienne)
This is a clean cherry-pick from master, there were no conflicts while cherry-picking. This is a dependency of bug 990003 which should be uplifted to v1.4.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Decoupling needed for bug 990003
[User impact] if declined: Cannot uplift bug 990003 to v1.4
[Testing completed]: The patch doesn't require any modifications and has already been used in master for a while
[Risk to taking this patch] (and alternatives if risky): Uplifting the dependencies without this patch is unrealistic
[String changes made]: None
Attachment #8446514 - Flags: approval-gaia-v1.4?(release-mgmt)
Comment on attachment 8446514 [details] [diff] [review]
Cherry-picked patch for v1.4

Approved for 1.4.
Attachment #8446514 - Flags: approval-gaia-v1.4?(release-mgmt) → approval-gaia-v1.4+
You need to log in before you can comment on or make changes to this bug.