Text selection keyboard shortcuts not working

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: cbaba20, Assigned: jchen)

Tracking

28 Branch
Firefox 32
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox30 verified, firefox31 verified, firefox32 verified, fennec+)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

Downloading such keyboard applications like Swift keyboard or Hackers keyboard etc and use it as a input tool .
using shortcut keys are is the main aim such CTRL+P,CTRL+V,CTRL+X etc.
step 1: Download the hacker's keyboard app from playstore.
step 2: use as by default 
step 3: open ff 28 or above browser ,type any link in url or any site name and use the CTRL key and go for paste to any where like in other tab, or in clipboard .
  


Actual results:

there is nothing happens (copy,paste or any other functions) and there must use another method to use functions .



Expected results:

After using extended functional keyboard application firefox must be work with them .
example : CTRL+C- For Copy 
                 CTRL+X- For Cut  etc .....
Are only the text selection related shortcut keys not working? Are other shortcuts working? Which device is this?

Firefox 28 has bug 768667 which implemented a new text-selection action-bar, perhaps that might be related to refactoring changes in shortcuts .. maybe? Wes?
Flags: needinfo?(wjohnston)
Flags: needinfo?(cbaba20)
I get the same behavior on 27, 28, and 31. i.e. keyboard shortcuts work in web content but not in the urlbar.
Flags: needinfo?(wjohnston)
Aaron.... Its Samsung GT P-3100 TAB and text selection from contents works but in URL it Doesn't makes any changes.
I also applied the same process on other android devices but result is same what comes there.
Flags: needinfo?(cbaba20)
tracking-fennec: --- → ?
tracking-fennec: ? → +
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Summary: shortcut keys are not working after firefox 28 stable and firefox 31 nightly . works fine on firefox 25 and 26 and 27(all version aurora,nightly,and beta) → Text selection keyboard shortcuts not working
Assignee: nobody → nchen
The purpose of the removed code was to redirect key events to the URL bar when the focus is not on it. For example, if the focus is on search results, this code would let you start typing without focusing the URL bar first.

However, the code never really worked correctly with the new about:home, and I'm not sure we even want this functionality. Even if we do, I think we should remove this legacy code first, to fix regressions such as shortcuts not working.
Attachment #8423412 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8423412 [details] [diff] [review]
Remove legacy code for redirecting key events to URL bar (v1)

Review of attachment 8423412 [details] [diff] [review]:
-----------------------------------------------------------------

Go!
Attachment #8423412 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/40fb7eda2870
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Comment on attachment 8423412 [details] [diff] [review]
Remove legacy code for redirecting key events to URL bar (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): about:home rewrite

User impact if declined: Shortcut keys (Ctrl+C, Ctrl+V, etc.) do not work in URL bar

Testing completed (on m-c, etc.): Locally, m-c

Risk to taking this patch (and alternatives if risky): Small; patch only removes legacy code.

String or IDL/UUID changes made by this patch: None
Attachment #8423412 - Flags: approval-mozilla-beta?
Attachment #8423412 - Flags: approval-mozilla-aurora?
Attachment #8423412 - Flags: approval-mozilla-beta?
Attachment #8423412 - Flags: approval-mozilla-beta+
Attachment #8423412 - Flags: approval-mozilla-aurora?
Attachment #8423412 - Flags: approval-mozilla-aurora+
Verified as fixed on
Build: 32.0a1 (2014-05-22)
Device: Asus Transformer Pad (Android 4.2.1)
Verified as fixed on
Build: 31.0a2 (2014-05-22)
Device: Asus Transformer Pad (Android 4.2.1)
Verified as fixed in build 30.0b6
Device: Asus Transformer Pad TF300T (Android 4.1.1)

Based on Comment 12 and Comment 13 I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
Somewhat Works with Android 4.2.2 Moto G device
You need to log in before you can comment on or make changes to this bug.