Closed Bug 993265 Opened 6 years ago Closed 6 years ago

Bug 990533 made livemarks and special folders show the placeholder favicon

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: MattN, Assigned: mikedeboer)

References

Details

(Keywords: regression, Whiteboard: [Australis:P3-])

Attachments

(1 file)

Adding :not(#home-button) to .bookmark-item increased the specificity of the selector the amount of an ID selector (yes, this is unfortunately how :not works).

This overrode selectors like .bookmark-item[container][livemark] and the ones for special Places search folders (I'm not sure of the name) e.g. "Most Visited" which don't contain an ID. The "Bookmarks Toolbar" icon in the menu is also affected. I would recommend using another approach that avoids :not(#home-button) such as making the #home button selector use !important or just more specific.

P3- since "Most Visited" is on the bookmark toolbar by default and we used to ship a livemark by default (perhaps not anymore) so it's in primary UI on the bookmark toolbar for many users.
Flags: needinfo?(mdeboer)
Assignee: nobody → mdeboer
Flags: needinfo?(mdeboer)
Why is this all/all? AIUI only Linux is affected, is that right?
Flags: needinfo?(MattN+bmo)
This is MacOSX only, as is bug 990533.
Status: NEW → ASSIGNED
Flags: needinfo?(MattN+bmo)
OS: All → Mac OS X
Attachment #8403224 - Flags: review?(mak77) → review+
Thanks!

Pushed to fx-team as https://hg.mozilla.org/integration/fx-team/rev/fc36dfbc7a4e
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/fc36dfbc7a4e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8403224 [details] [diff] [review]
Patch v1: preserve bookmark folder icons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 990533
User impact if declined: Keeps the bookmark folder icons in-tact, also makes it so that we can uplift bug 990533 to aurora & beta.
Testing completed (on m-c, etc.): landed on m-c.
Risk to taking this patch (and alternatives if risky): minor.
String or IDL/UUID changes made by this patch: n/a.
Attachment #8403224 - Flags: approval-mozilla-beta?
Attachment #8403224 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 994094
Attachment #8403224 - Flags: approval-mozilla-beta?
Attachment #8403224 - Flags: approval-mozilla-beta+
Attachment #8403224 - Flags: approval-mozilla-aurora?
Attachment #8403224 - Flags: approval-mozilla-aurora+
I was able to confirm the fix for this issue on Mac OS X 10.9 [1], using:
* the latest Beta (Build ID: 20140410150427),
* Aurora 2014-04-11 (Build ID: 20140411004002),
* Nightly 2014-04-11 (Build ID: 20140411030201).

1. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
You need to log in before you can comment on or make changes to this bug.