Closed Bug 993268 Opened 9 years ago Closed 7 years ago

Card EF File load end time issue.

Categories

(Firefox OS Graveyard :: RIL, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-)

RESOLVED WONTFIX
blocking-b2g -

People

(Reporter: duckhyun.chae, Unassigned)

Details

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; CNS_UA; AD_LOGON=4C47452E4E4554)

Steps to reproduce:

When Gecko is booting or Card refresh, it receive a message named ""RIL:CardStateChanged" from telephony layer.

When the data.cardState of the message is "ready", actually  this is before the telephony layer loads EF Files.
If the other component immediately try to access the EF File data after receiving this message, the component will get the abnormal EF Data.

Please check log time below.

We want to know the exact end time of loading or updating the EF files.

[Logs]
05:41:05.569 SendCardState ready  // Telephony Layer
05:41:05.599 I/Gecko   (  212): -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"cardState":"ready"}}
05:41:06.069 EF Load Complete!!!       // Telephony Layer


Actual results:

When Gecko is booting or Card refresh, it receive a message named ""RIL:CardStateChanged" from telephony layer.

When the data.cardState of the message is "ready", actually  this is before the telephony layer loads EF Files.
If the other component immediately try to access the EF File data after receiving this message, the component will get the abnormal EF Data.

Please check log time below.

We want to know the exact end time of loading or updating the EF files.

[Logs]
05:41:05.569 SendCardState ready  // Telephony Layer
05:41:05.599 I/Gecko   (  212): -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"cardState":"ready"}}
05:41:06.069 EF Load Complete!!!       // Telephony Layer


Expected results:

When Gecko is booting or Card refresh, it receive a message named ""RIL:CardStateChanged" from telephony layer.

When the data.cardState of the message is "ready", actually  this is before the telephony layer loads EF Files.
If the other component immediately try to access the EF File data after receiving this message, the component will get the abnormal EF Data.

Please check log time below.

We want to know the exact end time of loading or updating the EF files.

[Logs]
05:41:05.569 SendCardState ready  // Telephony Layer
05:41:05.599 I/Gecko   (  212): -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"cardState":"ready"}}
05:41:06.069 EF Load Complete!!!       // Telephony Layer
Hi Ken, Wayne,

Could you please check this issue?

Many Thanks
OS: All → Gonk (Firefox OS)
Priority: -- → P2
Hardware: All → ARM
Summary: [MADAI]Card EF File load end time issue. → Card EF File load end time issue.
Ken, can you put someone on this?

thanks
Flags: needinfo?(kchang)
Edgar, it seems that you handled this kind of bugs before.
Assignee: nobody → echen
Flags: needinfo?(kchang)
Hi DuckHyun:

(In reply to DuckHyun from comment #0)
> User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/6.0;
> SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media
> Center PC 6.0; InfoPath.3; .NET4.0C; CNS_UA; AD_LOGON=4C47452E4E4554)
> 
> Steps to reproduce:
> 
> When Gecko is booting or Card refresh, it receive a message named
> ""RIL:CardStateChanged" from telephony layer.
> 
> When the data.cardState of the message is "ready", actually  this is before
> the telephony layer loads EF Files.
> If the other component immediately try to access the EF File data after
> receiving this message, the component will get the abnormal EF Data.

Hi DuckHyun:

Does the other component get EF data from "Telephony Layer"?
(I guess "Telephony Layer" is partner's module.)

Sending "RIL:CardStateChanged" with "ready" state means card is ready to be used (for example, pin is unlocked).
It doesn't mean EF data is been loaded in "Telephony Layer".

I think "Telephony Layer" should have a it's own way to notify the EF is loaded and ready to be accessed.
Does it make sense?

Thank you.
Flags: needinfo?(duckhyun.chae)
Hi Edgar,

As you know, the ready does not mean that EF data has been loaded in telephony module.

The RIL IPC Message to notify RILContentHelper of EF data loaded doesn't exist.
I think that a specific ipc message that both RILContentHelper and telephony partner module know have to added. (Ex RIL:CardEFDataLoaded ...)
Or the field of "RIL:CardStateChanged" have to added.

Thank you.
duckhyun.
Flags: needinfo?(duckhyun.chae)
Flags: needinfo?(echen)
Are you talking about oniccinfochanged?
(In reply to DuckHyun from comment #5)
> Hi Edgar,
> 
> As you know, the ready does not mean that EF data has been loaded in
> telephony module.
> 
> The RIL IPC Message to notify RILContentHelper of EF data loaded doesn't
> exist.
> I think that a specific ipc message that both RILContentHelper and telephony
> partner module know have to added. (Ex RIL:CardEFDataLoaded ...)
> Or the field of "RIL:CardStateChanged" have to added.

Hi DuckHyun:

Could you provide more information about what EF you are interesting in?
If those EF are loaded by MOZ RIL, we will notify "RIL:IccInfoChanged" when it's ready.

Thank you.

> 
> Thank you.
> duckhyun.
Flags: needinfo?(echen) → needinfo?(duckhyun.chae)
blocking-b2g: --- → backlog
Hi Edgar,

Actually we're interested in EF Data(EF_IMPI, EF_DOMAIN, EF_IMPU, EF_IST, EF_PCSCF) of the ISIM applet for Our IMS Component.
But RilContext only save CdamIccInfo and GsmIccInfo. not save ISIM Iccinfo.
If possible, could you add iccInfo field for ims ef data or add the new message that other component know time for all ef loaded?
Please review the issue. and we'll review to use "RIL::IccInfoChanged" for our logic.

thanks for your help.
duckhyun.
Flags: needinfo?(duckhyun.chae) → needinfo?(echen)
(In reply to DuckHyun from comment #8)
> Hi Edgar,
> 
> Actually we're interested in EF Data(EF_IMPI, EF_DOMAIN, EF_IMPU, EF_IST,
> EF_PCSCF) of the ISIM applet for Our IMS Component.
> But RilContext only save CdamIccInfo and GsmIccInfo. not save ISIM Iccinfo.
> If possible, could you add iccInfo field for ims ef data or add the new
> message that other component know time for all ef loaded?

Hi DuckHyun, as you mention, moz ril doesn't handle those EFs of ISIM because we don't need those data right now. I am wondering is it possible to load those data in your IMS component?

> Please review the issue. and we'll review to use "RIL::IccInfoChanged" for
> our logic.
> 
> thanks for your help.
> duckhyun.
Flags: needinfo?(echen)
blocking-b2g: backlog → -
Assignee: echen → nobody
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.