Closed Bug 993293 Opened 6 years ago Closed 5 years ago

[setting] Previewing the ringtones is different from volume panel`s channel

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1043762
tracking-b2g backlog

People

(Reporter: oedipus31, Assigned: scheng)

References

Details

(Keywords: regression, Whiteboard: [priority][LibGLA,dev, B])

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Steps to reproduce:

Firefox OS v1.4
1. settings - Tones`s Ringer
2. play any ringtone. 
3. control volume by side key


Actual results:

Previewing the ringtones is different from volume panel`s channel.
AudioContext `s channel is AUDIO_CHANNEL_RINGER
but, AudioTrack`s stream type is AUDIO_STREAM_SYSTEM
It is related by Bug 958470.


Expected results:

If you control volume panel ,  The ringtone should lower or louder when is playing sound.
blocking-b2g: --- → 1.4?
QA Wanted to check to see if this happens on 1.3.
Component: Gaia::Settings → Gaia::Ringtones
Keywords: qawanted
ux to weigh in on volume of ringtone experimentation from settings
Flags: needinfo?(firefoxos-ux-bugzilla)
Issue does NOT occur in latest 1.3

Result: Changing volume using volume up and down hardware buttons affects ringer preview volume in settings

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140410004002
Gaia: 62acb4b0e774b6709b8be400d849f807404bb21b
Gecko: 94baf6039462
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: bzumwalt
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dkuo)
Eric,
Please provide your analysis for Audio Channel. What's your take on impact here?
Flags: needinfo?(echou)
Flagging Tiffanie on ringtones.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(tshakespeare)
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> Eric,
> Please provide your analysis for Audio Channel. What's your take on impact
> here?

I'll take a first look.
The difference between 1.3 and 1.4 about the ringtones app's audio channel is, for 1.3 the mozAudioChannelType property is set to the audio element, and 1.4 is set to the audio context. To my understanding, if an audio element or audio context has set to some type of audio channel, it should both follow the audio channel behaviour, which means the 'audio-channel-changed' mozChromeEvent will also fire when the target audio element or audio context is active, then system app is able to adjust the active channel.

I haven't take a detail look into this bug but maybe related to the audio context since web audio is still experimental.
Flags: needinfo?(dkuo)
I slightly investigated and had a discussion with Star, the solution of this bug may be the same as bug 984498. Both of them need to set AudioContext to correct AudioChannelType.

Delegate to Star for further investigation.
Assignee: nobody → scheng
Flags: needinfo?(echou)
Component: Gaia::Ringtones → AudioChannel
QA Contact: bzumwalt → pcheng
blocking-b2g: 1.4? → backlog
Whiteboard: [priority]
Hey all - I'm adding Omega who has been doing a lot of work on how all our sounds and audio.
Flags: needinfo?(tshakespeare) → needinfo?(ofeng)
When previewing ringers/alerts/alarm sounds,
1) the preview volume should reflect the corresponding one,
2) and the volume can be modified by hardware volume keys instantly.
Flags: needinfo?(ofeng)
Duplicate of this bug: 1019294
Whiteboard: [priority] → [priority][LibGLA,dev, B]
Can you get back to me it is availible to fix the scenario on v2.0?
Flags: needinfo?(jsmith)
It isn't fixed for 2.0 as of right now.
Flags: needinfo?(jsmith)
It is as the same as bug 1043762. To discuss in that bug, so mark this bug as duplicate.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043762
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.