Closed Bug 993299 Opened 7 years ago Closed 7 years ago

Australis - There is no minimum width set in customization mode

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: cornel_ionce, Assigned: jaws)

References

Details

(Whiteboard: [Australis:P3])

Attachments

(1 file)

This bug was filled as a follow up from bug 952191 (com 7).

STR:
1. Open Firefox.
2. Enter Customization mode.
3. Make the browser window as small as you can.
4. Customize the browser.

Results:
Customization mode can't be used if the window is too small.
There is no browser minimum width in the Customization mode.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Attachment #8403401 - Flags: review?(mconley)
Comment on attachment 8403401 [details] [diff] [review]
Patch

Easy peasy.
Attachment #8403401 - Flags: review?(mconley) → review+
 2:04.21 INFO TEST-START | Shutdown
 2:04.21 Browser Chrome Test Summary
 2:04.21        Passed: 1715
 2:04.21        Failed: 0
 2:04.21        Todo: 0
Keywords: checkin-needed
Whiteboard: [Australis:P3]
https://hg.mozilla.org/integration/fx-team/rev/215a4e3e1471
Keywords: checkin-needed
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/215a4e3e1471
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31
Comment on attachment 8403401 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): missed this case in bug 897160
User impact if declined: customization mode window can be too small to be useful
Testing completed (on m-c, etc.): on m-c for a couple days now
Risk to taking this patch (and alternatives if risky): none expected 
String or IDL/UUID changes made by this patch: none
Attachment #8403401 - Flags: approval-mozilla-aurora?
Attachment #8403401 - Flags: approval-mozilla-beta?
Attachment #8403401 - Flags: approval-mozilla-beta?
Attachment #8403401 - Flags: approval-mozilla-beta+
Attachment #8403401 - Flags: approval-mozilla-aurora?
Attachment #8403401 - Flags: approval-mozilla-aurora+
Verified fixed on Windows 7 64bit, Ubuntu 12.04 and Mac OS X 10.9 using:
# latest Nightly, build ID: 20140413030203
# latest Aurora, build ID: 20140413004003.
QA Contact: cornel.ionce
Also verified on Fx 29 beta 8, build ID: 20140414143035.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.