Closed Bug 993327 Opened 6 years ago Closed 6 years ago

[tarako] unable to enable Data Connect after turning off WIFI

Categories

(Firefox OS Graveyard :: Wifi, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified

People

(Reporter: angelc04, Assigned: vchang)

Details

(Whiteboard: [p=1])

Attachments

(3 files)

Steps to reproduce
-------------------------------------------------------------------
1. Start device
2. Enable Data connection
3. Enable WIFI, WIFI icon appears on status bar
4. Pull down tray bar, Turn off WIFI
   --> repeat 3~4 for several times, you will be able to see that Data connection icon does not appear on Status bar even when WIFI turns off.


Test build
-------------------------------------------------------------------
Gaia      9afe8145b5d309bdf2ef196b559e6dfd997faeeb
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/c2a0ee7b4d58
BuildID   20140407164002
Version   28.1
ro.build.version.incremental=eng.cltbld.20140407.202457
ro.build.date=Mon Apr  7 20:25:04 EDT 2014
After this issue is reproduced, toggling WIFI icon for several times can recover from it.
Attachment #8403159 - Attachment mime type: text/x-vhdl → text/plain
need to trace wifi part to see if correct wifi state was updated.

"Don't connect data call when Wifi is connected." <- this means RadioInterface treats WIFI is still connected.


04-08 14:29:42.050    84    84 I Gecko   : -*- RadioInterfaceLayer: 'ril.data.enabled' is now true
04-08 14:29:42.050    84    84 I Gecko   : -*- RadioInterfaceLayer: Default id for data call: 1
04-08 14:29:42.050    84    84 I Gecko   : -*- RadioInterface[1]: Don't connect data call when Wifi is connected.
blocking-b2g: --- → 1.3T?
Hi Vincent, could you help on this issue? thanks!
Flags: needinfo?(vchang)
Is this same cause of Bug 989717?
Flags: needinfo?(chulee)
Attached file 993327.log
timestamp: after 11:24:03.463.
(In reply to shawn ku [:sku] from comment #5)
> Created attachment 8403733 [details]
> 993327.log
> 
> timestamp: after 11:24:03.463.

The last state of wifi in NetworkManager is CONNECTED, looks like Wifi stuck in CONNECTED state.

04-09 11:13:30.934    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 1
04-09 11:13:30.934    83    83 I Gecko   : -*- NetworkManager: Evaluating whether active network needs to be changed.
04-09 11:13:30.934    83    83 I Gecko   : -*- NetworkManager: Found our preferred type of network: wlan0
04-09 11:13:30.964    83    83 I Gecko   : -*- RadioInterface[0]: Disconnect data call when Wifi is connected.
(In reply to shawn ku [:sku] from comment #5)
> Created attachment 8403733 [details]
> 993327.log
> 
> timestamp: after 11:24:03.463.

Based on the log here, it seems that wifi disable settings change event is not received in gecko. Need to add more log to confirm if it is a gaia bug.
Flags: needinfo?(vchang)
I extracted some important part in the log, it seems there are two set of wifi disable and enable operations:

Wifi Disable
> 04-09 11:24:13.863    83   331 W WifiHW  : wifi_command: TERMINATE
> 04-09 11:24:14.263    83    83 I Gecko   : -*- WifiWorker component: Event coming in: CTRL-EVENT-TERMINATING  - recv error
> 04-09 11:24:14.263    83    83 I Gecko   : -*- WifiWorker component: State change: UNINITIALIZED -> DISCONNECTED
> 04-09 11:23:14.653    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 3

Wifi Enable
> 04-09 11:23:19.563    83    83 I Gecko   : -*- WifiWorker component: detected SDK version 15
> ...
> 04-09 11:23:30.143    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 1
> 04-09 11:23:30.223    83    83 I Gecko   : -*- RadioInterface[0]: Disconnect data call when Wifi is connected.
> 04-09 11:23:30.563    83    83 I Gecko   : -*- RadioInterface[0]: Don't connect data call when Wifi is connected.
> 04-09 11:23:31.703    83    83 I Gecko   : -*- RadioInterface[0]: Don't connect data call when Wifi is connected.

Wifi Disable
> 04-09 11:23:41.203    83   331 W WifiHW  : wifi_command: TERMINATE
> 04-09 11:23:41.483    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 3
> 04-09 11:23:41.663    83    83 I Gecko   : -*- WifiWorker component: Event coming in: CTRL-EVENT-TERMINATING  - recv error
> 04-09 11:23:41.663    83    83 I Gecko   : -*- WifiWorker component: State change: UNINITIALIZED -> DISCONNECTED
> 04-09 11:23:47.483    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 3

Wifi Enable
> 04-09 11:23:51.683    83    83 I Gecko   : -*- WifiWorker component: detected SDK version 15
> ...
> 04-09 11:24:01.633    83    83 I Gecko   : -*- NetworkManager: Network wlan0 changed state to 1
> 04-09 11:24:01.663    83    83 I Gecko   : -*- RadioInterface[0]: Disconnect data call when Wifi is connected.
> 04-09 11:24:01.863    83    83 I Gecko   : -*- RadioInterface[0]: Don't connect data call when Wifi is connected.
> 04-09 11:24:03.473    83    83 I Gecko   : -*- RadioInterface[0]: Don't connect data call when Wifi is connected.
Flags: needinfo?(chulee)
The log seems normal to me, since we don't know the corresponding testing operation, maybe we need to track the status in quick settings app?
not sure if Arthur will have further input?
Flags: needinfo?(arthur.chen)
Component: RIL → Wifi
Assignee: nobody → vchang
Due to TERMINATE command error, manager.state is switched to "UNINITIALIZED" state before we receive the CTRL-EVENT-TERMINATING state change event. It makes the DISCONNECTED event being discarded and doesn't notify NetworkManager that wifi is done. I'll try to provide a patch tomorrow.
Flags: needinfo?(arthur.chen)
triage: 1.3T+ to make sure data is recoverd after turing off wifi
ni? vchang, is this tarako only? thanks
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(vchang)
Attachment #8404412 - Flags: review?(chulee)
Flags: needinfo?(vchang)
Comment on attachment 8404412 [details] [diff] [review]
Patch v1.0 for branches 1.3t and m-c

Review of attachment 8404412 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thank you~
Attachment #8404412 - Flags: review?(chulee) → review+
Whiteboard: [p=1]
Target Milestone: --- → 1.4 S6 (25apr)
Attachment #8404412 - Attachment description: Patch v1.0 for 1.3t → Patch v1.0 for branches 1.3t and m-c
https://hg.mozilla.org/mozilla-central/rev/459aaf00db94
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified the fix.  Turning off wifi repeatedly no longer prevents the data connection from occurring.

1.3 Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140429014002
Gaia: b5adc5a943d3abbd6ab070a47c847f2c24891cc5
Gecko: e9890f5d4709
Version: 28.1
Firmware Version: sp6821
You need to log in before you can comment on or make changes to this bug.