[layout view] Move the guides around the region currently hovered in the layout view

RESOLVED DUPLICATE of bug 994729

Status

defect
RESOLVED DUPLICATE of bug 994729
5 years ago
10 months ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=js][mentor=pbrosset])

(Reporter)

Description

5 years ago
Our new box-model highlighter is awesome, and having the guides helps a lot.
The highlighter appears when hovering over the regions in the layout view, but it would help understand better if the guides where displayed around the region currently being hovered.

So, if you currently are hovering over the padding region, it'd be nice to have the guides displayed around the padding region in the highlighter.
(Reporter)

Comment 1

5 years ago
I'm going to flag this as a good first bug because, even if there's quite a bit of work to be done, 99% of it has to be done in one file (toolkit/devtools/server/actors/highlighter.js), just making sure the position of the guides defined in the BoxModelHighlighter class can be configured. I have worked on a patch recently that hasn't landed that needed this, so I can provide pretty detailed pointers to whoever feels like working on this bug.
Whiteboard: [good first bug][lang=js][mentor=pbrosset]
(Reporter)

Updated

5 years ago
Blocks: firebug-gaps
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994729
(Reporter)

Updated

5 years ago
No longer blocks: firebug-gaps

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.