Closed Bug 993879 Opened 6 years ago Closed 5 years ago

samsung.com sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: haseeb, Unassigned, Mentored)

References

()

Details

(Whiteboard: [country-all][serversniff][contactready])

No description provided.
I suppose we could spoof as Tizen.. :-p
Whiteboard: [country-in2] → [country-all]
This site intends to send mobile browsers to a mobile site, but fails to detect that Firefox OS devices are smartphones.

Firefox OS is redirected to /no/, Firefox for Android and Safari on iPhone are redirected to http://m.samsung.com/

Selected HTTP response headers (Firefox OS, Firefox on Android, Safari on iPhone):

Response for: 'Mozilla/5.0 (Mobile; rv:30) Gecko/30 Firefox/30'
Response Status: 301
content-length: 0
location: /no/

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 301
content-length: 0
location: http://m.samsung.com/

Response for: 'Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25'
Response Status: 301
content-length: 0
location: http://m.samsung.com/
Whiteboard: [country-all] → [country-all][mentor=miketaylr][serversniff][contactready]
Daniel, could you help us find someone at Samsung who is in charge of the Web sites?
Flags: needinfo?(daniel)
If no luck, we can also try  Darren Bellinger - Samsung.com Operations Developer. 
http://uk.linkedin.com/pub/darren-bellinger/23/528/43
http://www.ur1webdesign.co.uk/portfolio.php
Mentor: miket
Whiteboard: [country-all][mentor=miketaylr][serversniff][contactready] → [country-all][serversniff][contactready]
This was fixed. Maybe Thanks to Daniel.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(daniel)
Resolution: --- → FIXED
(In reply to Karl Dubost :karlcow from comment #5)
> This was fixed. Maybe Thanks to Daniel.

I reported the issue but never heard back. Glad it's fixed though.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.