Closed Bug 993913 Opened 7 years ago Closed 7 years ago

remove the %user_cache from inline history, and ensure the object cache is always used

Categories

(bugzilla.mozilla.org Graveyard :: Extensions: InlineHistory, defect)

Production
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glob, Assigned: dylan)

Details

(Keywords: perf)

Attachments

(1 file)

inline history maintains its own cache of user objects, however this is no longer required since the object cache was introduced.

- remove %user_cache completely from Extension.pm
- update the Bugzilla::User->new() call to use the cache
Status: NEW → ASSIGNED
Assignee: nobody → dylan
Is this what you had in mind? Nothing is ever this simple...
Attachment #8404281 - Flags: feedback?(glob)
Comment on attachment 8404281 [details] [diff] [review]
bug-993913-v1.patch

Looks correct to to me.
Attachment #8404281 - Flags: feedback+
Attachment #8404281 - Flags: review?(dkl)
Comment on attachment 8404281 [details] [diff] [review]
bug-993913-v1.patch

Review of attachment 8404281 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8404281 - Flags: review?(dkl)
Attachment #8404281 - Flags: review+
Attachment #8404281 - Flags: feedback?(glob)
Committed 43572df
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: bugzilla.mozilla.org → bugzilla.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.