Table displayed in the wrong place

RESOLVED DUPLICATE of bug 14984

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 14984
16 years ago
16 years ago

People

(Reporter: Ariel Gonzalez, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2001-09-10-03, win2kps2

In the above URL, the table that is supposed to be placed at the bottom of the
page is placed in the middle of the text, in the middle of the page.

Comment 1

16 years ago
Created attachment 49219 [details]
Testcase

Comment 2

16 years ago
This bug might be invalid, the testcase has this rule:
DIV.maintext {
	border: 1px solid red;
	width: 65%;
	float: right;
	float: top;
}

and we are ignoring "float: top" and using "float: right" which I think is the
correct way to do it. Navigator 4.x seems to ignore the whole rule.
(NS4.x displayes it as Mozilla if I remove "float: top").
Assignee: attinasi → dbaron
Component: Layout → Style System
Keywords: testcase
OS: Windows 2000 → All
QA Contact: petersen → ian
(Assignee)

Comment 3

16 years ago
'float: bottom' does not exist in CSS2:
http://www.w3.org/TR/REC-CSS2/visuren.html#float-position .  The overlap is a
duplicate of bug 14984.  Marking duplicate of bug 14984.

*** This bug has been marked as a duplicate of 14984 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
(I _think_ David meant 'float: top' does not exist in CSS2)
(Assignee)

Comment 5

16 years ago
Yeah, I did, but they're both true statements. :-)
You need to log in before you can comment on or make changes to this bug.