Closed Bug 994116 Opened 8 years ago Closed 8 years ago

about:support - move Graphics info higher than Modified Prefs

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox31 --- verified

People

(Reporter: vlad, Assigned: aryx)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

The "Important Modified Preferences" information is often very spammy, because all of the printer prefs are included there.  It's also a variable-length list, causing the user to need to scroll a bunch.

One of the most common pieces of information that we ask users for is their Graphics info, which is below the prefs list.  Can we move "Important Modified Preferences" to the end of the list (and perhaps rename it "Modified Preferences", but that has l10n impact and I don't really want to deal with that)?  Then the list would look like:

Basics
Crash Reports
Extensions
Graphics
JavaScript
Accessibility
Library Versions
Experimental Features
... and then Modified Preferences bringing up the rear.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8404154 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/mozilla-central/rev/b9ddd0b1f398
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla31
Hey, thanks for jumping on this so quickly!  I didn't get a chance to look back at this until just now.  Any reason to have just moved the Graphics section up one chunk?  The others (JavaScript, Accessibility, Experimental Features) are just as higher importance than "Modified Preferences" and are also fixed length.  Modified Prefs really should go to the very end of the list.
Hi, sorry for the late answer. From my glimpses into an end user support channel, Modified Preferences provided important information for malware infected computers who monetize through ad popups etc. The Graphics are helpful when it comes to crashes, especially the ones caused by hardware acceleration. JavaScript, A11y and Experimental Features aren't/won't be that common in end user support. Supporters sometimes also use tools like Adwcleaner to retrieved the Modified Preferences information.

Chris Ilias: Because developers and end users have different priorities on that page, what should the order of categories be? We could ifdef release builds, but in my humble opinion, I don't see the clear benefit of that.
Flags: needinfo?(bmo2010)
I've started a thread in the sumo community forum <https://support.mozilla.org/en-US/forums/contributors/710238>.

Once we've got an order of categories for you, I'll post back here and remove the needinfo flag.
If the decided order is different than the current one, I'll file a new bug.
Flags: needinfo?(bmo2010)
Great, thanks -- separate bug is the way to go.  I couldn't figure out how to reply on the support page, but I agree with the-edmeister's comments.

One thing that's important to note: modified prefs *would* be important to be near the top, *if* the only prefs that showed up were actually important modified prefs.  Unfortunately, we use prefs for a lot of things that are not at all important -- e.g. 20 individual prefs *per printer* that you've ever used.  Printing is probably the worst offender, but a lot of other systems use prefs to store last-modified times and other bits of info.  As it is, basically every user will have something in the "modified preferences" list.  So the presence of a modified preference doesn't mean much by itself; someone still has to actually look at the pref names and values.  That's why I suggested that it should move to the bottom; it's the only thing on that page that is not a fixed size.

There are definitely additional tweaks that could be made to make that page better; for example, the "copy data" buttons really should stand out more and ideally have icons associated with them.  There's so much stuff on the page that directing a user to copy the contents and paste it in an email/support request would be (imo) much easier if you could say "press the green button with the clipboard picture" rather than "look for the copy to clipboard button".
After discussing it in the sumo community forum, I think the current order is best.

Reason: With no one having an opinion or data regarding if the graphics section is used often enough to put above prefs, I think we should play it safe and put it above prefs.
QA Whiteboard: [good first verify]
Tested on Mac OS X 10.9. 

Before:

Firefox 30 has the Graphics information after the Imported Modified Preferences.

After:

Firefox 31 has the Graphics information before the Imported Modified Preferences. The order of the sections matches the proposal in the Description, in as far as the things I actually have in my Firefox installation.
QA Whiteboard: [good first verify] → [good first verify][bugday-20140716]
Works/fixed/resolved

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
BuildID 20140714151536

[bugday-20140716]
QA Whiteboard: [good first verify][bugday-20140716] → [bugday-20140716]
You need to log in before you can comment on or make changes to this bug.