Closed Bug 994232 Opened 7 years ago Closed 2 years ago

crash in @0x0 | SweepZones

Categories

(Core :: JavaScript: GC, defect)

29 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox29 --- affected

People

(Reporter: jbecerra, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-47fe28cb-d759-454d-9440-478d42140409.
=============================================================

This started happening with Firefox 29.0b6 (20140407), mostly on Windows XP followed by Windows 7. No comments associated with the reports. Most of the URLs associated with this are on facebook.com

0 		@0x0 	
1 	mozjs.dll 	SweepZones 	js/src/jsgc.cpp
2 	mozjs.dll 	EndSweepPhase 	js/src/jsgc.cpp
3 	mozjs.dll 	IncrementalCollectSlice 	js/src/jsgc.cpp
4 	mozjs.dll 	GCCycle 	js/src/jsgc.cpp
5 	mozjs.dll 	Collect 	js/src/jsgc.cpp
6 	mozjs.dll 	js::GC(JSRuntime *,js::JSGCInvocationKind,JS::gcreason::Reason) 	js/src/jsgc.cpp
7 	mozjs.dll 	JSRuntime::~JSRuntime() 	js/src/vm/Runtime.cpp
8 	mozjs.dll 	JS_DestroyRuntime(JSRuntime *) 	js/src/jsapi.cpp
9 	xul.dll 	mozilla::CycleCollectedJSRuntime::~CycleCollectedJSRuntime() 	xpcom/base/CycleCollectedJSRuntime.cpp
10 	xul.dll 	`anonymous namespace'::WorkerJSRuntime::~WorkerJSRuntime() 	dom/workers/RuntimeService.cpp
11 	xul.dll 	`anonymous namespace'::WorkerThreadPrimaryRunnable::Run() 	dom/workers/RuntimeService.cpp
12 	xul.dll 	nsThread::ProcessNextEvent(bool,bool *) 	xpcom/threads/nsThread.cpp
13 	xul.dll 	NS_ProcessNextEvent(nsIThread *,bool) 	xpcom/glue/nsThreadUtils.cpp
14 	xul.dll 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) 	ipc/glue/MessagePump.cpp
15 	xul.dll 	_SEH_epilog4 	
16 		@0x893f874 	
17 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c
18 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c
19 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c
20 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c
21 	kernel32.dll 	kernel32.dll@0x1495d 	
22 	ntdll.dll 	ntdll.dll@0x498ee 	
23 	ntdll.dll 	ntdll.dll@0x498c4
I think this is caused by the first patch for bug 986843 landing on the 29 branch.  The second patch should have fixed it now.
Crash Signature: [@ @0x0 | SweepZones] [@ js::GC(JSRuntime *,js::JSGCInvocationKind,JS::gcreason::Reason)] → [@ @0x0 | SweepZones] [@ js::GC(JSRuntime *,js::JSGCInvocationKind,JS::gcreason::Reason)] [@ js::GC]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.