getUserMedia problem with FFOS1.3 + Keon

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: laaglu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
Posted file test.html
User Agent: Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 2014031500

Steps to reproduce:

Hi,

I am the author of a FFOS/openwebapp dictaphone application based on WebRTC/getUserMedia + IndexedDB, see:
https://marketplace.firefox.com/app/dictaphone/
http://fos-apps.org/

I develop on Peak + FFOS1.2, Revolution + FFOS1.3 and various versions of FF-desktop and FF-android where the application works fine. I have had reports from Keon/FFOS1.3 users that the app is not working on their terminal. From the symptoms, I suspect there might be a problem with getUserMedia on Keon/FFOS1.3. 

I have created a test case to try to reproduce the problem:
http://fos-apps.org/test.html

and posted on the Keon dev list where one user has confirmed the problem:
https://forum.geeksphone.com/index.php?topic=6044.0

I am including my test case as an attachment to this report: open it with the Keon 1.3 browser and click the test button. 



Actual results:

This should trigger the FFOS permission dialog asking for the permission to use the microphone but it does not seem to be the case. That would imply that calls to getUserMedia on Keon1.3 do not trigger callbacks (neither success nor error) or throw exception.




Expected results:

Based on this data, I am submitting this bug report to get confirmation or rebuttal of the problem and info and who should fix the problem if it is real (geeksphone or mozilla). Please accept my apology if this turns out to be an invalid bug report.

Comment 1

5 years ago
I have the same issue on my Geeksphone Keon with Firefox OS 1.3 provided by Geeksphone on the 19th of April 2014. I tested with the application dictaphone as the test page is not available anymore.
Reporter

Comment 2

5 years ago
I have restored the test page at http://fos-apps.org/test.html
Test page is gone again, but I can confirm this bug on my Keon with Gaia 2,0 running. 

Device: Geeksphone Keon
Build: 20140512024602
Gaia: 014d16ea
Platform Version: 32.0a1

The difference to Comment 0 is that, permission dialog displays every time after tapping record button, and it looks like it is recording in the app since the recorded length is correct. However when replaying it plays only TV tuning sounds.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

a year ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.