Intermittent e10s geolocation/test_windowClose.html | [SimpleTest.finish()] this test already called finish! | called finish() multiple times

RESOLVED FIXED in Firefox 30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: billm)

Tracking

({intermittent-failure})

Trunk
mozilla32
x86
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(e10s+, firefox30 fixed, firefox31 fixed, firefox32 fixed, firefox-esr24 wontfix, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=37516362&tree=Fx-Team

Ubuntu VM 12.04 fx-team pgo test mochitest-e10s-3 on 2014-04-09 08:47:33 PDT for push 382ebd5e9589
slave: tst-linux32-spot-123

08:53:38     INFO -  1768 INFO TEST-START | /tests/dom/tests/mochitest/geolocation/test_windowClose.html
08:53:38     INFO -  *** WIFI GEO: Sending request: http://127.0.0.1:8888/tests/dom/tests/mochitest/geolocation/network_geolocation.sjs
08:53:38     INFO -  *** WIFI GEO: sending {}
08:53:38     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:38     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: Sending request: http://127.0.0.1:8888/tests/dom/tests/mochitest/geolocation/network_geolocation.sjs
08:53:39     INFO -  *** WIFI GEO: sending {}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: Sending request: http://127.0.0.1:8888/tests/dom/tests/mochitest/geolocation/network_geolocation.sjs
08:53:39     INFO -  *** WIFI GEO: sending {}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: Sending request: http://127.0.0.1:8888/tests/dom/tests/mochitest/geolocation/network_geolocation.sjs
08:53:39     INFO -  *** WIFI GEO: sending {}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  1769 INFO TEST-INFO | MEMORY STAT vsize after test: 499597312
08:53:39     INFO -  1770 INFO TEST-INFO | MEMORY STAT residentFast after test: 96055296
08:53:39     INFO -  1771 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 21250760
08:53:39     INFO -  1772 INFO TEST-INFO | dumping last 2 message(s)
08:53:39     INFO -  1773 INFO TEST-INFO | if you need more context, please use SimpleTest.requestCompleteLog() in your test
08:53:39     INFO -  1774 INFO TEST-PASS | /tests/dom/tests/mochitest/geolocation/test_windowClose.html | no crash, so pass.
08:53:39     INFO -  1775 INFO TEST-PASS | /tests/dom/tests/mochitest/geolocation/test_windowClose.html | no crash, so pass.
08:53:39     INFO -  1776 INFO TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/geolocation/test_windowClose.html | [SimpleTest.finish()] this test already called finish!
08:53:39     INFO -  1777 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/geolocation/test_windowClose.html | called finish() multiple times
08:53:39     INFO -  *** WIFI GEO: Sending request: http://127.0.0.1:8888/tests/dom/tests/mochitest/geolocation/network_geolocation.sjs
08:53:39     INFO -  *** WIFI GEO: sending {}
08:53:39     INFO -  *** WIFI GEO: gls returned status: 200 --> {"status":"OK","location":{"lat":37.41857,"lng":-122.08769},"accuracy":42}
08:53:39     INFO -  1778 INFO TEST-END | /tests/dom/tests/mochitest/geolocation/test_windowClose.html | finished in 1143ms
The test is calling Geolocation.watchPosition and then, in the callback, SimpleTest.finish. The problem is that SimpleTest.finish is somehow getting called more than once.

The documentation for Geolocation.watchPosition says that it can call the callback more than once. SimpleTest.finish looks kind of asynchronous. So I think we just need to avoid calling it more than once.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8407029 - Flags: review?(dougt)
Comment on attachment 8407029 [details] [diff] [review]
geolocation-close

Review of attachment 8407029 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/tests/mochitest/geolocation/windowTest.html
@@ +13,5 @@
>  <body>
>  <a target="_blank" href="https://bugzilla.mozilla.org/show_bug.cgi?id=493615">Mozilla Bug 493615</a>
>  <p id="display"></p>
>  <div id="content" style="display: none">
>    

while you're here, this white space can be removed.
Attachment #8407029 - Flags: review?(dougt) → review+
Bill, is there any reason this hasn't landed yet? :)
Flags: needinfo?(wmccloskey)
No. Can you please land? I think I've forgotten it twice because the tree was closed when I tried to land.
Flags: needinfo?(wmccloskey)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6bb86257e36a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.