Closed Bug 994558 Opened 6 years ago Closed 6 years ago

Incoherence between number of suggestions and number of items displayed in suggestion list

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 987075

People

(Reporter: cawang, Unassigned)

Details

(Whiteboard: ux-most-wanted)

Attachments

(1 file)

Repro Steps:
1) In Dialer, input phone numbers
2) After three digits input, the system displays the matched results from contacts (1st screen of the attachment).
3) Tap the number of the matched results
4) Display the result (3 items a page, see the 2nd screen of the attachment)

Actual:
The page doesn't look like action menu and it only displays three items per page. kind of wasting the space.  

Expected:
It should be the action menu from building block and a page can display more than 3 items in this case.
blocking-b2g: --- → 2.0?
Whiteboard: ux-most-wanted
Blocks: 994991
Summary: [Dialer] Wrong action menu for matched result → Incoherence between number of suggestions and number of items displayed in suggestion list
I've opened bug 995128 for the look of the suggestion list. Let's keep this bug on the incoherence between number of suggestions and number of items displayed.
While reviewing bug 987075, I've just noticed that there are no incoherences. It's just a weird cropped list. You can scroll it and all matches are visible when you scroll inside it. Bug 987075 will fix this by expanding the list to the full screen.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987075
No longer blocks: 994991
Removing 2.0? flag.
Bug 987075 will fix this issue and it is under the Dialer visual refresh work committed for 2.0
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.