Closed Bug 994900 Opened 6 years ago Closed 6 years ago

LockscreenWindow causes B2G Desktop to show blank window with gaia debug profile

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: qdot, Assigned: qdot)

References

Details

(Whiteboard: [systemsfe])

Running B2G Desktop with a debug gaia profile and lockscreen on causes it to come up with a screen that just shows wallpaper and the battery icon. Reverting commit 71e9afe (https://github.com/mozilla-b2g/gaia/commit/71e9afe) fixes it, so something in the LockscreenWindow patch (bug 937442) is causing this issue.
Do you mean STR is:

1. DEBUG=1 make
2. <B2G-desktop-bin> -P <the path to the profile-debug>

I want to make sure I haven't misunderstood what did you mean before I start to debug it.
Flags: needinfo?(kyle)
Oh, yeah, sorry, should've put a full repro. I use:

DEBUG=1 DESKTOP=0 make

Otherwise the desktop shims cause issues with b2g desktop.
Flags: needinfo?(kyle)
OK. Thanks. I would start debugging.
I've followed your STR but can't reproduce the bug. Please see the video to find whether I've did it wrong or something we may missing on the bug:

http://youtu.be/sh2ufyFLuJw
Flags: needinfo?(kyle)
Hmm. only difference is that I was running this on linux x86-64 (Debian jessie), though since this is a gaia issue I don't see how platform would matter much. That's obviously running the debug profile too, since it's having the same issues loading collection/dock icons that we're seeing in bug 995006. :)

Did you build your own B2G Desktop or pull off tbpl?
Flags: needinfo?(kyle)
I download it from

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/

I think we should test it more, and may have more results from different people to confirm this bug.
I tried downloading the latest nightly for linux x86_64, generating a debug gaia profile, and copying it into the b2g/gaia/profile directory. Sure enough, I get the same error as listed in Comment 0. I then tried it on my OS X machine, and managed to also get the same error. Wallpaper with battery icon, no other interface (Though the new bottom bar home button that's part of the shell now comes up, but that just landed today).

Rewatching your video, it looks like we tried the same steps but are getting completely different results, so I'm not sure what's going on here. On my OS X machine, I was using a fresh checkout of gaia and the nightly built on tbpl.
I of course using the newest Gaia on the B2G desktop. So, the only difference may be the version of the B2G desktop. I may try different versions to confirm that. If it cause the bug, I would say it's not completely LockSreenWindow's fault, but maybe some interactive issues caused it.

By the way, can you take a screenshot of the symptom to help me understand what happened?
Got fixed at some point because I've been running debug for a while now with no issues. Closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.