Closed Bug 995074 Opened 5 years ago Closed 5 years ago

Can't customize shortcuts on Mac

Categories

(Firefox :: Untriaged, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 429824

People

(Reporter: philippzins, Unassigned)

Details

Attachments

(1 file)

Attached image bug.jpg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36

Steps to reproduce:

1. Add "⇧⌘C" as a shortcut for web console under System Preferences > Keyboard >  App Shortcuts > Firefox.
2. Press "⇧⌘C" in Firefox.


Actual results:

Nothing.


Expected results:

Open web console.

You can actually see in the menubar that the shortcut has changed. Very weird: If the submenu for this in the menubar it open it actually works! But it should work with a closed menu, too.
Thanks for reporting this. 
It seems to be a duplicate of Bug 429824.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
(In reply to Tiziana Sellitto [:tiziana] from comment #1)
> It seems to be a duplicate of Bug 429824.

How can all symptom of "Can't customize shortcuts on Mac" be same same problem as a phenomenon of "Can't customize shortcuts on Mac" which was reported on 2008-04-19?
How did you find that this bug on ac OS X 10_9_2, Firefox 29 is same problem as that bug which was reported on on 2008-04-19?

Re-opening.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(In reply to philippzins from comment #0)
> You can actually see in the menubar that the shortcut has changed.
> Very weird: If the submenu for this in the menubar it open it actually works!
> But it should work with a closed menu, too.

Similar wired phenomenon was reported to a forum in Japan on Mac OS X 10_9, Firefox 29, for Command-Q, Option-Command-Q etc. in Firefox menu of Menu Bar.

Does customized "⇧⌘C" work by following?
1. Start Firefox
2. Add "⇧⌘C" as a shortcut, under System Preferences > Keyboard >  App Shortcuts > Firefox.
3. Expand Firefox's menu, and confirm that "⇧⌘C" is shown for the menu item.
4. Collapse Firefo's menu. Keep Firefox as active application.
5. Press "⇧⌘C"
   Does "⇧⌘C" work as expected?
(In reply to WADA from comment #2)
> (In reply to Tiziana Sellitto [:tiziana] from comment #1)
> > It seems to be a duplicate of Bug 429824.
> 
> How can all symptom of "Can't customize shortcuts on Mac" be same same
> problem as a phenomenon of "Can't customize shortcuts on Mac" which was
> reported on 2008-04-19?
> How did you find that this bug on ac OS X 10_9_2, Firefox 29 is same problem
> as that bug which was reported on on 2008-04-19?
> 
> Re-opening.

Sorry. Maybe I've done an error of valuation, it seemed to me that the symptom of this bug could be originated from the bug related.
(In reply to philippzins from comment #0)
> You can actually see in the menubar that the shortcut has changed. Very
> weird: If the submenu for this in the menubar it open it actually works! But
> it should work with a closed menu, too.

It looks that symptom is not unchanged since Firefox  3 RC1.
i.e. duping to Bug 429824 itself was correct, after removing "Quit Firefox(Comand-Q) cases" from dup chain of Bug 429824, even if "duping to Bug 429824" is pretty confusing.
See meta Bug 1015670 please, if you actually want problem like this bug will be resolved at buzilla.mozilla.org.

Closing as dup of Bug 429824 again.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.