Closed Bug 995093 Opened 5 years ago Closed 5 years ago

Add a marionette test to check Keyboard app could show up correctly.

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: evanxd, Assigned: GaryChen)

References

Details

Attachments

(1 file, 3 obsolete files)

Add a marionette test to check Keyboard app could show up correctly.
We have gaia-ui-tests that already cover this.
Hi Jan,

Yes, but we also need this test in js-marionette.
And this bug is blocking Bug 993247.
Hi Evan, 
   Please help to review this patch, thanks.
Attachment #8405219 - Flags: review?(evanxd)
Hi Gary,

Just left comments for your patch.
Nice work! :)
Blocks: 993247
Please review this patch again. thanks.
Attachment #8405219 - Attachment is obsolete: true
Attachment #8405219 - Flags: review?(evanxd)
Attachment #8405294 - Flags: review?(evanxd)
Hi Evan,
   I can not see any comments what you list links on comment #7, could you left you comment again?

   Thanks
Attachment #8405841 - Attachment is obsolete: true
Flags: needinfo?(evanxd)
Rudy is helping to debug the intermittent issues.
Flags: needinfo?(evanxd)
Comment on attachment 8405842 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/18241

Hi Evan,
   I just clean up this patch, please review it again.
   I'll re-run travis after bug 997045 is landed.

   thanks.
Attachment #8405842 - Flags: review?(evanxd)
We could review the patch after Bug 997045 is done.
Thanks.
Please be informed that I've sent another pull request for stability check, which already contains the patches in Bug 997045.
 - https://github.com/mozilla-b2g/gaia/pull/18443

For the keyboard marionette-js test itself, it still needs some changes as the commit shows,
https://github.com/RudyLu/gaia/commit/71d3202684d91b086080eed5a350f0f3a59a2dad
Hi Rudy and Evan,
   I just addressed your comments on my patch please help to take a look.
   https://github.com/mozilla-b2g/gaia/pull/18241
   Thanks.
Flags: needinfo?(rlu)
Flags: needinfo?(evanxd)
Thanks for incorporating my changes into the patch.
BTW, the tests are not going to pass since my patches into marionette-apps is not merged yet, and we're working on that.
Flags: needinfo?(rlu)
Comment on attachment 8405842 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/18241

Just comment on the pull request with some suggestions/nits.
Thanks.
Attachment #8405842 - Flags: feedback+
We should just wait for Bug 997045 is fixed, then we could review the patch.
Thanks.
Flags: needinfo?(evanxd)
Hi Evan and Rudy,
   Thanks for your wonderful works on bug 997045.
   I just update my code base and trigger travis again.

   Please help to reive my patch thanks.
   https://travis-ci.org/mozilla-b2g/gaia/builds/24083761
Flags: needinfo?(rlu)
Flags: needinfo?(evanxd)
Yeah, I also did the stability test again with the latest Gaia change,
https://github.com/mozilla-b2g/gaia/pull/18443

Need Evan's help to review it again and then we could merge this change!
Flags: needinfo?(rlu)
Left comments in the GitHub page.
Flags: needinfo?(evanxd)
Comment on attachment 8405842 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/18241

Hi Gary,
r+, nice work!
Flags: needinfo?(evanxd)
master: 1aeff97ba68fdb0fc36eaa29627bf1834043c7e3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Gary and Rudy,

Do you guys have badg.us accounts?
You got the Marionette Starter awards.
http://badg.us/en-US/badges/badge/Marionette-Starter
Flags: needinfo?(rlu)
Flags: needinfo?(gchen)
We finally have marionette tests for keyboard app. It will let us have less regression. Nice!
(In reply to Evan Tseng [:evanxd][:愛聞插低] from comment #24)
> Hi Gary and Rudy,
> 
> Do you guys have badg.us accounts?
> You got the Marionette Starter awards.
> http://badg.us/en-US/badges/badge/Marionette-Starter

Sure, my account is mmm198219@gmail.com.
Thanks again.
Flags: needinfo?(gchen)
Evan, Gary,

Thanks for making this happen.

--
I'll send Evan my account info to get the badge. :)
Flags: needinfo?(rlu)
Attachment #8405842 - Flags: review?(evanxd) → review+
You need to log in before you can comment on or make changes to this bug.