Closed Bug 995157 Opened 6 years ago Closed 6 years ago

Tabs opened in guest mode can be synced

Categories

(Firefox for Android :: Android Sync, defect)

Firefox 31
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: CristinaM, Assigned: nalexander)

Details

Attachments

(1 file)

Environment:
Build 31.0a1 (2014-04-10)
Devices: Nexus 4(4.4.2) and Asus Transformer (Android 4.2.1)

Steps to reproduce:
1. Set up a new Firefox Account and log in on two devices.
2. Start Firefox on one device, switch to a Guest session and navigate to a site.
3. Force a Sync.
4. On the second device go to synced tabs.

Expected result: 
The tab opened in guest session doesn't appear at synced tabs on the second device.

Actual result:
The tab opened in guest session appear at synced tabs on the second device.
Component: General → Android Sync
Product: Firefox for Android → Android Background Services
Version: Trunk → Firefox 31
If Fennec writes the tab record to the DB, Sync will see it and include it in the outbound tabs upload.  My guess is that Fennec shouldn't be writing the tab record: since the tabs DB is strictly for Sync's use, non-Sync items shouldn't be written; but I'll need to investigate.

ni to me to investigate and re-file as a Fennec issue if necessary; ni to wesj for a comment about use of the tabs DB, since I believe he implemented much of guest mode.
Flags: needinfo?(wjohnston)
Flags: needinfo?(nalexander)
This sure looks like Bug 957131 for the tabs content provider.  Changed assumptions for the loss :|
Flags: needinfo?(nalexander)
Assignee: nobody → nalexander
wesj: yep, this is an android-sync thing.  Bug 957131 squashed some, but not all, the issues.  I'm going to audit the remaining places before posting patches.
Status: NEW → ASSIGNED
Flags: needinfo?(wjohnston)
(In reply to Nick Alexander :nalexander from comment #4)
> Created attachment 8409271 [details] [review]
> Link to Github pull-request:
> https://github.com/mozilla-services/android-sync/pull/454

Works well locally (at least the tabs part; I didn't dig in to the clients part too deeply).
Comment on attachment 8409271 [details] [review]
Link to Github pull-request: https://github.com/mozilla-services/android-sync/pull/454

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  Don't know. Presumably it's been a while.
 
User impact if declined: 
  Interplay between Guest Mode use and tab sync leads to data leakage.

Testing completed (on m-c, etc.): 
  Hasn't landed yet, just getting this request in early!

Risk to taking this patch (and alternatives if risky): 
  Should be slim -- it adds the correct 'profile' argument to the URIs that Sync uses to talk to the tabs database.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8409271 - Flags: review?(rnewman)
Attachment #8409271 - Flags: review+
Attachment #8409271 - Flags: approval-mozilla-aurora?
In an email thread, rnewman raised the question of whether tabs are written to the DB during guest browsing, and whether they accumulate or are purged.  Tabs are written to the DB during guest browsing, and the entire guest profile is deleted at the end of the guest session, so they are purged.
https://hg.mozilla.org/mozilla-central/rev/f6b4679502a9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Flags: needinfo?(cristina.madaras)
Keywords: verifyme
I'm not able to reproduce this anymore on Nightly (2014-04-08), using Nexus 4 (Android 4.4.2) and Asus Transformer (Android 4.2.1). This seems to be fixed.
Flags: needinfo?(cristina.madaras)
I wanted to say Nightly (2014-04-21). Sorry for that!

(In reply to cristina.madaras from comment #10)
> I'm not able to reproduce this anymore on Nightly (2014-04-08), using Nexus
> 4 (Android 4.4.2) and Asus Transformer (Android 4.2.1). This seems to be
> fixed.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Attachment #8409271 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.