Closed Bug 995173 Opened 7 years ago Closed 7 years ago

[Messages] The in-app notification for the "message is too big" state should not disappear after 2 seconds

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S6 (25apr)
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: julienw, Assigned: julienw)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

From Bug 990481:

STR:
* attach enough less-than-300k videos to display the in-app notification that the message is too big.

Expected:
* the notification is displayed and stays in place

Actual:
* the notification is displayed but disappears.

That's a regression from bug 952109.
Assignee: nobody → felash
Attachment #8405365 - Flags: review?(schung)
Attached file 2nd proposal: github PR for v1.3 (obsolete) —
Attached file 1st proposal: github PR (obsolete) —
Attachment #8405369 - Flags: review?(schung)
Hey Steve,

I made 2 proposals here:

* 1st proposal: keeps basically the same way of working than before except we can decide whether the notice is transient

I found that it has an issue: when the user reaches the message max length, and then just focus the subject and focus elsewhere, the notice would be removed. This happens because both the message max length and subject max length notices share the same DOM object.

That's why I made the 2nd proposal, slightly more changes, but in the end it's simpler because they don't share a DOM element anymore.

I actually do prefer the 2nd proposal but I wanted to take your advice too.
blocking-b2g: 1.3? → backlog
Can we please have a rationale for the minusing?

* regression
* bad for UX and thus for the user
* simple patch

If it's not blocking for 1.3 (because at this stage we want to let only critical patch in), is it for 1.4?
blocking-b2g: backlog → 1.3?
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Can we please have a rationale for the minusing?
> 
> * regression
> * bad for UX and thus for the user

I wouldn't call a severe UX fallout. It's a minor UX fallout at best, as the message is still presented to show the error.

> * simple patch

This has no influence on a blocking decision.

> 
> If it's not blocking for 1.3 (because at this stage we want to let only
> critical patch in), is it for 1.4?

comment 5 isn't enough to block. At this point, it has to be a cert blocker in order to block 1.3. This likely wouldn't block 1.4 either, as it's a minor regression at best. We can consider this for approval though.
blocking-b2g: 1.3? → backlog
Attachment #8405369 - Flags: review?(schung)
Comment on attachment 8405365 [details] [review]
2nd proposal: github PR for master

I agree we should sperate the notification into different element because both of them might show up in the same time but different reason.
Since this bug is move to backlog, how about we think for farther: We put the notification into another widget and generate it with template only when we need it. That could clean up the thread_ui and index.html a little bit. wdyt?
Attachment #8405366 - Attachment is obsolete: true
Attachment #8405369 - Attachment is obsolete: true
(In reply to Steve Chung [:steveck] from comment #7)
> Comment on attachment 8405365 [details] [review]
> 2nd proposal: github PR for master
> 
> I agree we should sperate the notification into different element because
> both of them might show up in the same time but different reason.
> Since this bug is move to backlog, how about we think for farther: We put
> the notification into another widget and generate it with template only when
> we need it. That could clean up the thread_ui and index.html a little bit.
> wdyt?

Actually I like the current simplicity of having these notices with a constant text (except for one) and displaying them when needed.

Using a template makes sense when we have one layout and changing and unpredictable text (like for displaying a thread... where we don't use templates yet ;) ). But here I feel it's unnecessary because we have constant texts and using simple DOM is good enough. It's not like we have dozens of different notices, we have only 3 (the 4th is different). If we have more in the future we can definitely revisit your proposal though !
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #8)
> (In reply to Steve Chung [:steveck] from comment #7)
> > Comment on attachment 8405365 [details] [review]
> > 2nd proposal: github PR for master
> > 
> 
> Actually I like the current simplicity of having these notices with a
> constant text (except for one) and displaying them when needed.
> 
> Using a template makes sense when we have one layout and changing and
> unpredictable text (like for displaying a thread... where we don't use
> templates yet ;) ). But here I feel it's unnecessary because we have
> constant texts and using simple DOM is good enough. It's not like we have
> dozens of different notices, we have only 3 (the 4th is different). If we
> have more in the future we can definitely revisit your proposal though !

Ok then let's focus on 2nd proposal for now and I'll review it later.
Flags: needinfo?(schung)
Comment on attachment 8405365 [details] [review]
2nd proposal: github PR for master

Only some small nits but overall looks good, thanks!
Attachment #8405365 - Flags: review?(schung) → review+
Fixed the nits, rebased with conflicts, so waiting for a green travis before merging.
Flags: needinfo?(felash)
master: 9f12ef085ff8095d5da81ea1658e4705013fd64e
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(felash)
Resolution: --- → FIXED
Comment on attachment 8405365 [details] [review]
2nd proposal: github PR for master

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 952109
[User impact] if declined: The banner explaining that the max length has been reached disappears after 2 seconds, and as a result the user things the issue is only transient while it's really permanent.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low, there is unit tests and the changes itself is not risky
[String changes made]: no
Attachment #8405365 - Flags: approval-gaia-v1.4?
Comment on attachment 8405365 [details] [review]
2nd proposal: github PR for master

for incorrect UX on the user
Attachment #8405365 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
This issue has been verified fixed on v1.4 on the following devices:

Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140522000200
Gaia: 233dd43b3b976e66a619dbc1b4044ed1e3ca3e34
Gecko: c3c0c57daef8
Version: 30.0
RIL Version:
Firmware Version: v1.2-device.cfg

Environmental Variables:
Device: Flame v1.4 MOZ ril
BuildID: 20140522000200
Gaia: 233dd43b3b976e66a619dbc1b4044ed1e3ca3e34
Gecko: c3c0c57daef8
Version: 30.0
Firmware Version: v10F-3

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140522000200
Gaia: 233dd43b3b976e66a619dbc1b4044ed1e3ca3e34
Gecko: c3c0c57daef8
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
This issue is verified fixed on the Buri v2.0 master:

Environmental Variables:
Device: Buri v2.0 MOZ ril
BuildID: 20140522040230
Gaia: ef66efa34ed8a559c8998bde688fae88eb943a7a
Gecko: b40296602083
Version: 32.0a1
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.