Support rendering single-width and single-color rounded dashed/dotted borders

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 382721
3 years ago
2 years ago

People

(Reporter: Takeshi Kurosawa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8405816 [details] [diff] [review]
Part 1: Extract stroke dash setting code into a method (with whitspace and typo fixes)

Add fast path for rendering single-width and single-color rounded dashed / dotted borders using |Stroke()|.

Upcoming patches will support borders like:
div {
border-width: 5px; /* single-width */
border-color: pink; /* single-color */
border-style: dashed; 
}

Upcoming patches will not support borders like:

div {
border-width: 5px 10px; /* not single-width */
border-color: pink; /* single-color */
border-style: dashed; 
}

div {
border-width: 5px; /* single-width */
border-color: pink red; /* not single-color */
border-style: dashed; 
}
(Reporter)

Comment 1

3 years ago
Created attachment 8405817 [details] [diff] [review]
Part 2: Support rendering single-width and single-color rounded dashed/dotted borders
(Reporter)

Comment 2

3 years ago
Created attachment 8405823 [details]
Screenshot of Attachment 673358 [details] and Attachment 8386965 [details]

Screenshot of Attachment 673358 [details] and Attachment 8386965 [details] from Bug 382721.

Comment 3

3 years ago
Why does Firefox still (I'm on 33.1) not support rounded AND dotted/dashed borders?
Even IE gets it done...

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.