Last Comment Bug 99578 - Evangelism - translate evangelism letters to Hebrew
: Evangelism - translate evangelism letters to Hebrew
Status: RESOLVED FIXED
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: Hebrew (show other bugs)
: unspecified
: All All
: -- normal
: ---
Assigned To: Prognathous
: Jon Rubin
:
Mentors:
http://www.mozilla.org/projects/tech-...
Depends on:
Blocks: 86690
  Show dependency treegraph
 
Reported: 2001-09-14 00:33 PDT by Shoshannah Forbes
Modified: 2015-04-19 23:45 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Evangelism letter - Hebrew (2.64 KB, application/x-zip-compressed)
2003-01-18 15:54 PST, Prognathous
no flags Details
The letter in my Mozilla- terribly broken (50.59 KB, image/gif)
2003-01-18 16:41 PST, Shoshannah Forbes
no flags Details
Layout under Mozilla1.3b/Win32 (57.92 KB, image/x-png)
2003-01-18 17:03 PST, Prognathous
no flags Details
Evangelism letter - Hebrew (second draft) (2.44 KB, application/x-zip-compressed)
2003-03-25 02:47 PST, Prognathous
no flags Details
Evangelism letter - Hebrew (third draft) (2.47 KB, application/x-zip-compressed)
2003-03-25 10:41 PST, Prognathous
no flags Details
Evangelism letter - Hebrew (#4) (2.53 KB, application/x-zip-compressed)
2003-03-25 15:29 PST, Prognathous
no flags Details
Changes to the letter text, that eliminate gender bias (3.24 KB, application/rtf)
2003-03-27 11:09 PST, Shoshannah Forbes
no flags Details
Evangelism letter - Hebrew (gender-free version) (2.56 KB, application/x-zip-compressed)
2003-03-30 07:17 PST, Prognathous
no flags Details
Evangelism letter - Hebrew (gender-free version; letter-he.css) (2.56 KB, application/x-zip-compressed)
2003-03-31 04:37 PST, Prognathous
no flags Details
Evangelism letter - HTML version (5.13 KB, text/html)
2003-06-06 07:43 PDT, Prognathous
no flags Details
Short Hebrew letter (1.03 KB, text/plain)
2003-06-11 15:23 PDT, Shoshannah Forbes
no flags Details
This is the correct short Hebrew letter version (1.02 KB, text/plain)
2003-06-11 15:26 PDT, Shoshannah Forbes
no flags Details

Description Shoshannah Forbes 2001-09-14 00:33:16 PDT
Looks like it is time to transalete to Hebrew. I guess I will do it, althugh I
won't be that quick (will be going next week to france, hope to work on this in
the middle of a bunch of other stuff)
Comment 1 Prognathous 2002-05-07 16:51:33 PDT
Are there any updates about this one? I hope you are not held back by the lack of a Hebrew reviewer. If this is the case, I'll be happy to step in and help.
Comment 2 Bob Clary [:bc:] 2002-05-07 17:11:05 PDT
No, we don't have any translation done so far. If you are willing please let me
know. There are some overall changes I would like to make to the basic letters,
so don't start until you correspond or speak to me. You can come to #evangelism
on irc and we can talk about it.
Comment 3 Tomer Cohen :tomer 2002-10-10 16:50:41 PDT
Any progress about this? I would like to help, in case it's needed.
Comment 4 Shoshannah Forbes 2003-01-13 01:44:56 PST
After the talk at: http://www.mozilla.org.il/board/viewtopic.php?p=619 Assigning to Prognathous@hotmail.com
Comment 5 Prognathous 2003-01-13 06:00:10 PST
Accepting.

Let's continue the discussion in the mozilla.org.il thread...

Prog.
Comment 6 Prognathous 2003-01-18 15:54:43 PST
Created attachment 111945 [details]
Evangelism letter - Hebrew

First draft.

Open issues:

* Singular vs. Plural use. Whom are we addressing, a team or an individual?

* Hebrew vs. Latin transliteration. IMO, "JavaScript" doesn't look right
transliterated to Hebrew.

* Lack of several technical Hebrew terms (e.g. "The Web" is *not* the same as
"The Internet".)

* Less than stellar layout, especially when viewed with IE6. I'll let Shosh
deal with that one...

BTW, the mozilla.org.il forum seems buggy, perhaps we should go on in here
after all. Is there any way to make Bugzilla display Hebrew characters without
resorting to attachments?

Prog.
Comment 7 Shoshannah Forbes 2003-01-18 16:38:12 PST
The file looks all wonky in my Mozilla (see screen shot)- I guess I'll have to
take a look at the code later.

I didn't like all the English text in the middle of the Hebrew- I prefer
transliteration most times when no translation is avalible. The mixture of
English and Hebrew makes it messy.

I didn't like the male language of the document, with that horrible note at the
buttom- most cases can be written w/o gender.

Regarding web- there is no word for "web" vs. "internet" in Hebrew. I usally use
just "web site" vs. "the internet network" when I write in Hebrew.

בקשר לעברית בבאגזילה- אין לי מושג אם זה עובד. נראה עכשיו. בכל מקרה, לא כל מי
שקורא את זה יודע עברית...
Comment 8 Shoshannah Forbes 2003-01-18 16:41:09 PST
Created attachment 111948 [details]
The letter in my Mozilla- terribly broken
Comment 9 Prognathous 2003-01-18 17:03:23 PST
Created attachment 111952 [details]
Layout under Mozilla1.3b/Win32

> The file looks all wonky in my Mozilla (see screen shot)- I guess I'll have
to
> take a look at the code later.

OMFG. I've never seen anything like it! Check out the attached screenshot to
see the same page under Win32.

> I didn't like all the English text in the middle of the Hebrew- I prefer
> transliteration most times when no translation is avalible. The mixture of
> English and Hebrew makes it messy.

Perhaps it does make things messy, but transliterating common English terms
into very-uncommon (or new) Hebrew ones is even worse. 

> I didn't like the male language of the document, with that horrible note at 
> the buttom- most cases can be written w/o gender.

Agreed.

> Regarding web- there is no word for "web" vs. "internet" in Hebrew. I usally 

> use just "web site" vs. "the internet network" when I write in Hebrew.

Although not as precise as one would wish, "The Internet" should suffice IMO.

> ב&#1511.......

?

Prog.
Comment 10 Prognathous 2003-01-20 03:23:21 PST
See more comments and questions here: 
http://www.mozilla.org.il/board/viewtopic.php?p=670#670

Prog.
Comment 11 Bob Clary [:bc:] 2003-01-21 07:11:27 PST
doron, your help in reviewing this would be appreciated as well.
Comment 12 Bob Clary [:bc:] 2003-03-17 08:50:31 PST
the english and polish versions of the tech-letter-xx.html have been checked in.
What is the status of this translation? Has it been reviewed?
Comment 13 Prognathous 2003-03-18 01:31:28 PST
Unfortunately, no substantial review has been made, at least not one which 
offers alternative suggestions.
I did ask for additional comments, but it seems that some translation issues 
are not easy to solve, hence the lack of input.

Here are the main points:

* Should we translate technical English terms that do not have common Hebrew 
equivalents? Typical examples being CSS and plug-ins.

* Should we transliterate English names to Hebrew or leave them in English? In 
my opinion, most webmasters are more likely to have encountered "Gecko" written 
using in English characters - even within Hebrew texts.

* How does one translate terms like JavaScript, DHTML, Venkman, DOM, DevEdge, 
Sidebars and Debugger? is there any sense transliterating them? for the sake of 
readability, I believe that we should keep all of these terms in English, even 
if esoteric Hebrew terms exist.

* We definitely should aspire to write without gender, but in some cases this 
is unavoidable. "Dear webmaster" is such a case. Using plural as a way to 
bypass the gender issue just sounds unnatural, while being inconsistent and 
opting to mix genders randomly is even worse (I know Shosh disagrees with me on 
that one).

This above is based on a list of issues that I previously laid out in the 
Israeli Mozilla forum.
http://www.mozilla.org.il/board/viewtopic.php?t=103&start=15

Prog.
Comment 14 Tsahi Asher 2003-03-18 02:31:23 PST
i think the "custumize" parts should be translated to hebrew. there is no point
leaving them in english, except maybe for the bug ID number.

i also reccomend using the <BDO dir="rtl"> tag where needed, to overcome errors
created by the BiDi algorithm, such as writing the combination "4.x" the right
way. put inside a <bdo dir="ltr"> </bdo> it looks correct. it also helps in
seperating acronims from their meaning in brackets, such as the combination
"World Wide Web Consortium (W3C)". ading a <bdo> tag around the space before the
acronime will ensure correct text flow. e.g.

World Wide Web Consortium <bdo dir="rtl"> </bdo> (W3C)

lists seperated with comma can also be seperated with <bdo dir=rtl> over the
space, to maintain correct text flow.

notice that IE treats this tag a bit differently from Gecko.

you might also consider aligning the link to the bug to the right, and giving it
a LTR direction.
Comment 15 Prognathous 2003-03-18 03:19:45 PST
Thanks for the technical tips, Tsahi. We should integrate your suggestions into 
the page together with fixing the layout issues mentioned in Comment #7 (Shosh, 
have you found the cause?)

Now- do you have any comments regarding the text itself? any *specific* 
suggestions?

Prog.
Comment 16 Bob Clary [:bc:] 2003-03-18 08:06:09 PST
Ok, this is just my uninformed opinion but:

> * Should we translate technical English terms that do not have common Hebrew 
> equivalents? Typical examples being CSS and plug-ins.

No.

> * Should we transliterate English names to Hebrew or leave them in English? In
> my opinion, most webmasters are more likely to have encountered "Gecko" 
> written using in English characters - even within Hebrew texts.

No for something like Gecko.

> * How does one translate terms like JavaScript, DHTML, Venkman, DOM, DevEdge, 
> Sidebars and Debugger? is there any sense transliterating them? for the sake 
> of readability, I believe that we should keep all of these terms in English, 
> even if esoteric Hebrew terms exist.

Was it the general usage ? Is JavaScript translated? If not, then the other
shouldn't be either.
Comment 17 Prognathous 2003-03-18 08:55:13 PST
> Was it the general usage ? Is JavaScript translated?

There are several online JavaScript guides in Hebrew and at least two books
about the subject. They all keep the word "JavaScript" in English, and I don't
think that this choice disturbs many of the readers, quite the contrary.

You could also search Hebrew websites for the term. The result would show that
almost everyone keeps the word English, and only few use one of various Hebrew
transliterations.

Prog.
Comment 18 Tsahi Asher 2003-03-18 12:19:04 PST
it appears like you added some connecting words and "he hayedia" to correct the
text flow. so adding the <bdo> tag will allow you to remove them and be more
loyal to the original text.

you should also correct the underlines created by minus signs, to match the
length of the hebrew headers. hebrew is usually about 30% shorter than english.

Comment 19 Prognathous 2003-03-25 02:47:39 PST
Created attachment 118402 [details]
Evangelism letter - Hebrew (second draft)

Ok, draft #2 takes into account some of the suggestions. I also hacked the CSS
a bit, and now the letter looks much better on both platforms. I briefly tested
it with IE6 and Mozilla 1.3 on Win2k, and with Safari b62, Camino 0.7 and
Mozilla 1.3 on OS X and only found some relatively minor problems on the Mac
(Shosh could you please look into this?)

There are still several open issues:

* If we keep using monospace font (why?), I suggest that we specify Courier New
as I did in this CSS file. The default font for IE6 is Miriam Fixed and it
doesn't properly support the Maqaf punctuation mark.

* For consistency, the text is still written with male gender. Don't get me
wrong, I'm hardly enthusiastic about this myself, but until someone else steps
in and rephrases things better, I'm afraid that this is a compromise that we
have to make. There *are* quite a few places where we can be gender-free, but
should we waive consistency?

* I tried to by as loyal as possible to the original text, but in some cases
the result is a bit cumbersome (typical example being the Gecko detection
section). This could easily be solved by using a more loose translation, but
one that still keeps the original content and meaning intact.

* Using <bdo dir="ltr"> in an rtl paragraph seems buggy in 1.3, especially when
English comma separated lists are involved. I'll have to test this more
thoroughly (and search bugzilla...) before submitting a new bug. This is why I
only made partial use of this tag.

Prog.
Comment 20 Tsahi Asher 2003-03-25 09:02:39 PST
regarding comma-seperated lists: a code like 

HTML, <bdo dir="rtl"> </bdo> CSS

(you might need to play with the spaces here) will resemble a hebrew letter
between the "HTML" and the "CSS", and ensure the correct placement of the comma
and the correct flow of text. test this on IE too. i tried it on earlier
versions of moz than 1.3, and didn't have significant problems.

you also have an extra line between the "W3C technical reccomendations" header
and the "minus" line under it.

i think there suould also be a link to the page on mozdev with the sidebars.
this is possibly a bug in the original english letter.
Comment 21 Prognathous 2003-03-25 10:41:50 PST
Created attachment 118441 [details]
Evangelism letter - Hebrew (third draft) 

Fixed the letter according to Tsahi's suggestions. Anything else?

Prog.
Comment 22 Tsahi Asher 2003-03-25 13:52:02 PST
there is also a missing link at the Gecko DOM documentation.

devedge went trough major reconstruction recently, to make it comply with the
standards, so it's worth checking if all the links are correct.

other than that, the text looks fine.
Comment 23 Prognathous 2003-03-25 15:29:14 PST
Created attachment 118490 [details]
Evangelism letter - Hebrew (#4)

All the links are up to date.

For some reason, the part about "The Document Object Model in Mozilla" didn't
match the original text (was it recently updated?). Anyway, this is now fixed.

Prog.
Comment 24 Shoshannah Forbes 2003-03-27 11:08:32 PST
Looks decent in my nightly Camino, but I still don't like the Male languages.
What about the opening I am attching? (as bugzilla does not support inline Hebrew)
Comment 25 Shoshannah Forbes 2003-03-27 11:09:57 PST
Created attachment 118673 [details]
Changes to the letter text, that eliminate gender bias
Comment 26 Prognathous 2003-03-27 11:38:27 PST
It's a reasonable opening, but unfortunately the original meaning is lost.
"To the owners of the website" is not the same as "Dear Webmaster". In fact, 
you are addressing a completely different person, one who is more likely to be 
non-technical.

As a side note, if this (rather significant) change is acceptable, then I would 
definitely like to rephrase many other parts of the text, parts that sound a 
bit clumsy in Hebrew.

Bob, what is your stance about this issue? should readability and natural style 
be sacrificed for *exact* loyalty with the original text?

Prog.
Comment 27 Prognathous 2003-03-27 12:27:36 PST
Some comments about the rest of your suggestions:

Using "Inserting a technical description is required" instead of "Insert a 
technical description" is an option, but it sounds like hokey pharmacy talk 
IMO. The same with "It is recommended to visit mozilla.org's Web Developer 
site" instead of "Visit mozilla.org's Web Developer site".

The only way out of this could be to use plural form, but it would still look 
bad in some parts, especially in the opening: "Dear Webmasters"
Personally, I don't like this one bit.

Prog.
Comment 28 Shoshannah Forbes 2003-03-27 19:23:22 PST
Re Comment #26:
* In general, IMHO, this letter suffers too much of "Hebrish"- it is transalted
too closely to the literal meaning of the English words. 

* Even using "site building" and not "webmaster" loses meaning, as the webmaster
many times is the person who administrators the server, not the person who coded
the site. Therefore, IMNSHO, my version is not too far from the origianl, while
keeping the formality of the original ("Dear xxx" is a pretty formal opening).

* If you want to re-phrse the whole letter, go ahead as far as I am concereed.

* Do you have a better idea of phrasing that keeps it gender neutral?

---
Shoshannah, who manages a few web sites, and is sick and tired of emails
addressed to her position but apprently not to her, if to judge by the language.
BTW, emails like that are mentally flagged a "mass email", and thus I pay less
attention to them.
Comment 29 Bob Clary [:bc:] 2003-03-28 05:05:24 PST
"*exact* loyalty" to the english text is not required. Each language/culture has
it's own methods of communicating and I believe you should feel free to express
the ideas and information in a fashion which is best suited to the particular
audience. 

I do believe that a natural letter which the native reader knows is not a poor
translation will have much more effect than a "stilted" one which tries to
follow the english text too closely.

So, keep the information the same but tailor to your audience.
Comment 30 Prognathous 2003-03-30 07:17:07 PST
Created attachment 118899 [details]
Evangelism letter - Hebrew (gender-free version)

Yet another draft. 
Less "Hebrish" and no gender-bias (as far as I can see).

Prog.
Comment 31 Tsahi Asher 2003-03-30 11:32:36 PST
you said that you changed the css file, so you may need to change its name to
letter-he.css.
Comment 32 Prognathous 2003-03-31 04:37:13 PST
Created attachment 118935 [details]
Evangelism letter - Hebrew (gender-free version; letter-he.css)

Done. Anything else?

Prog.
Comment 33 Tsahi Asher 2003-05-03 01:26:42 PDT
is this going to be checked in sometime?
Comment 34 Bob Clary [:bc:] 2003-05-03 09:38:58 PDT
Ok, I will do it if everyone is happy with the current version.
Comment 35 Prognathous 2003-05-03 09:51:51 PDT
I believe that Tsahi, Shosh and I are all content with this version ->
http://mozilla.org.il/board/viewtopic.php?t=103&start=15

There were some concerns about the naming of new components, but this is more of
a general evangelism issue, not something that we should deal with in this bug.

Prog.
Comment 36 Bob Clary [:bc:] 2003-05-03 10:16:32 PDT
checked in as
http://www.mozilla.org/projects/tech-evangelism/site/letters/tech-letter-he.html,
added to NOWRAP and added a link from
http://www.mozilla.org/projects/tech-evangelism/site/letters/

Should be available in an hour or so, please confirm and mark this fixed if you
are happy.
Comment 37 Prognathous 2003-05-04 06:16:30 PDT
Under Gecko-based browsers as well as IE6, The letter is accessible, legible and
(hopefully) comprehensible ;-)

I'm happy with it. Resolving as Fixed.

Prog.
Comment 38 Prognathous 2003-06-06 07:43:35 PDT
Created attachment 125090 [details]
Evangelism letter - HTML version

Same as the last version, except that this one uses inline-CSS and hyperlinks
instead of URLs. 

Usefull for those (like myself) who prefer HTML-based emails as means to avoid
directionality issues. Plain text emails are too much of a hassle when using
Hebrew.

Prog.
Comment 39 Shoshannah Forbes 2003-06-11 15:22:23 PDT
I have found myself using a shorter version of the Hebrew evang letter. I am
attaching a copy in case anyone is intrested.
Comment 40 Shoshannah Forbes 2003-06-11 15:23:13 PDT
Created attachment 125456 [details]
Short Hebrew letter
Comment 41 Shoshannah Forbes 2003-06-11 15:26:57 PDT
Created attachment 125457 [details]
This is the correct short Hebrew letter version
Comment 42 Shoshannah Forbes 2003-06-17 00:34:43 PDT
please read my Comment #6 in bug #99578

The phrase that really got to him was "these next generation browsers"- he
claimed that that is a judgmental line, and we should avoid it. in general he
said that the letter is "mitnase" (patronalistic).
He also complained about lack of identification of who the sender of the letter
actaully is.

Althugh in general he was not very co-opertive, he might have a point- We stuck
pretty much to the english version, which might come thrugh as patronalistic in
Hebrew.

What do you think?
Comment 43 Shoshannah Forbes 2003-06-17 00:36:09 PDT
opps- should be comment #6 bug #160832
Comment 44 Prognathous 2003-06-17 02:31:50 PDT
> The phrase that really got to him was "these next generation browsers"- he
> claimed that that is a judgmental line, and we should avoid it. 

It is nothing more than a fair description of the truth. IE6 standards support
hasn't been updated for years. Gecko, on the other hand, has surpassed it in
this regard and is *constantly* being updated.

> in general he said that the letter is "mitnase" (patronalistic).

Just to make sure, I went and read both the short and the full version twice,
and I'm now convinced that neither of these letters is patronizing at all.

> He also complained about lack of identification of who the sender of the 
> letter actaully is.

That's a good point. Do we have any strict policy about it?

> Althugh in general he was not very co-opertive, he might have a point- We 
> stuck pretty much to the english version, which might come thrugh as 
> patronalistic in Hebrew.

I believe we've got ridden of most "Hebrish" in one of the last drafts. I
certainly don't think that we should "sachbakize" it any further. The way I see
it, this letter is meant to provide an official, non-colloquial, constructive
help. If people find that patronizing, they are probably the kind that won't
cooperate, regardless of the way it's phrased.

Prog.
Comment 45 Tsahi Asher 2003-06-17 04:49:19 PDT
bug 160832 comment 6
Comment 46 Tsahi Asher 2003-06-17 05:00:16 PDT
MS increased their support of W3C standards with IE6, and to my understanding,
it is better than with IE5. however, that's almost all of the improvements they
added in the last 5 years, since IE4 was released, other than print preview and
P3P support.

and if he couldn't figure out who sent it, maybe he didn't read it to the end. i
don't think it appears like coming from mozilla.org. maybe we can add a
disclaimer at the end, like "the writer of this message is not representing
mozilla.org".
Comment 47 Prognathous 2003-08-11 05:46:00 PDT
The short version of the letter should be added to the Hebrew component homepage:
 http://www.mozilla.org/projects/tech-evangelism/site/component-hebrew.html

In addition, you can count me in under Volunteers.

Thanks,

Prog.
Comment 48 Bob Clary [:bc:] 2003-08-13 04:17:29 PDT
Prog. I have added this to my local tree but don't have time to check it in
until this evening. This is a text file and may now display properly in all
browsers. We may want to change it to and HTML format like the other letters but
that can wait. 


Note You need to log in before you can comment on or make changes to this bug.