Closed Bug 995952 Opened 6 years ago Closed 6 years ago

Dynamic panel crash: NPE at org.mozilla.gecko.home.DynamicPanel$PanelDatasetLoader.loadCursor(DynamicPanel.java:417)

Categories

(Firefox for Android :: Awesomescreen, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 995420

People

(Reporter: Margaret, Unassigned)

References

Details

wesj told me he ran into this while testing his Twitter panel last week, but I haven't seen a bug filed on it. Looks like fallout from bug 976064.

E/GeckoAppShell( 7074): java.lang.NullPointerException
E/GeckoAppShell( 7074): 	at org.mozilla.gecko.home.DynamicPanel$PanelDatasetLoader.loadCursor(DynamicPanel.java:417)
E/GeckoAppShell( 7074): 	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:44)
E/GeckoAppShell( 7074): 	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:26)
E/GeckoAppShell( 7074): 	at android.support.v4.content.AsyncTaskLoader.onLoadInBackground(AsyncTaskLoader.java:242)
E/GeckoAppShell( 7074): 	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:51)
E/GeckoAppShell( 7074): 	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:40)
E/GeckoAppShell( 7074): 	at android.support.v4.content.ModernAsyncTask$2.call(ModernAsyncTask.java:123)
E/GeckoAppShell( 7074): 	at java.util.concurrent.FutureTask.run(FutureTask.java:234)
E/GeckoAppShell( 7074): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)
E/GeckoAppShell( 7074): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)
E/GeckoAppShell( 7074): 	at java.lang.Thread.run(Thread.java:841)
Oops, this was filed as bug 995420.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 995420
You need to log in before you can comment on or make changes to this bug.