Closed Bug 996097 Opened 6 years ago Closed 2 years ago

Dragging a tab and releasing it should show the tab sliding in to place instead of snapping in to place

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1355507

People

(Reporter: jaws, Unassigned)

Details

Attachments

(1 file)

Attached file Screencast of bug
When dragging a tab and releasing it, we snap the tab to its new place. We should instead show a transition where the tab slides in to place.

I think the best here would be if it slid over just a little and then back in to place. See the following ASCII art, step by step, to get an idea:

Tab should slide to line up with this vertical bar shown below:
                         v
_____/- New Tab ---\_____|__
_______/- New Tab ---\________
_________/- New Tab ---\________
___________/- New Tab ---\________
____________/- New Tab ---\________
___________/- New Tab ---\________
Final resting place -^
Updated with proper tab shape...

____⎰‾‾‾New Tab‾‾‾⎱_____
______⎰‾‾‾New Tab‾‾‾⎱_____
________⎰‾‾‾New Tab‾‾‾⎱_____
__________⎰‾‾‾New Tab‾‾‾⎱_____
___________⎰‾‾‾New Tab‾‾‾⎱_____
__________⎰‾‾‾New Tab‾‾‾⎱_____
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355507
You need to log in before you can comment on or make changes to this bug.