Closed Bug 996293 Opened 7 years ago Closed 7 years ago

[B2G][WebRTC][Browser] In Tarako, uploading a file from the phone in rtccopy.com will cause the user to exit out the room

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

RESOLVED DUPLICATE of bug 996141
1.4 S6 (25apr)
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: psiphantong, Unassigned)

Details

(Keywords: memory-footprint, perf, Whiteboard: 1.3tarakorun2, OOM, [c=memory p= s=2014.04.25 u=] [MemShrink:P3])

Attachments

(2 files)

Attached file chat.txt
When user uploads a file from the phone in rtccopy.com, the user will exit out the room

Repro Steps:
1) Got to rtccopy.com on desktop, create room
2) Join the same room via phone
3) Upload a file


Actual:
User gets kick out the room when uploading a file

Expected:
User should not get kick out the room when uploading a file

1.3 Environmental Variables:
Device: tarako 1.3 MOZ
BuildID: 20140414004001
Gaia: 0e7f21e61625b75a9149480cd5a259211549f020
Gecko: 3b02811c314a
Version: 28.1
Firmware Version: v1.2-device.cfg


Repro frequency: (3/3, 100%)
Link to failed test case: https://moztrap.mozilla.org/manage/case/11215/
See attached: (logcat)
Unable to reproduce this issue on the Buri v1.5, v1.4, v1.3 MOZ ril.

1.5 Environmental Variables:
Device: buri 1.5 MOZ
BuildID: 20140414040203
Gaia: f3abbd2d0a60f1a1618db93f8b1957cae6de379c
Gecko: 215080b813a7cd
Version: 31.0a1
Firmware Version: v1.2-device.cfg

Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140411000202
Gaia: 6c50349f41d40ba175ea0fc0c2c2cbd739ba7170
Gecko: 28b419f0e857
Version: 30.0a2
Firmware Version: v1.2-device.cfg


1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140414004002
Gaia: 8b92c56267fe50772095f1f25d6cc1f9c9966eb4
Gecko: 3e26908fca71
Version: 28.0
Firmware Version: v1.2-device.cfg
What type of file? Using what app to upload the file?
Flags: needinfo?(psiphantong)
upload any files from gallery, wallpaper, music, video, camera
Flags: needinfo?(psiphantong)
It looks like an OOM issue:
02-21 18:57:29.790: I/log(6628): <4>0[ 9588.623991] lowmem_shrink select 6475 (Browser), adj 10, size 7579, to kill
Keywords: footprint, perf
Whiteboard: 1.3tarakorun2 → 1.3tarakorun2, OOM, [c=memory p= s= u=] [MemShrink]
Are we supporting WebRTC on Tarako?
Whiteboard: 1.3tarakorun2, OOM, [c=memory p= s= u=] [MemShrink] → 1.3tarakorun2, OOM, [c=memory p= s= u=] [MemShrink:P3]
Running that web page, I ran into bug 998075

When trying to create a room, I OOM'ed within the browser app

Gaia      a8d2d399f2939f4845abaa0df57abab241a2c782
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d97dad54cb61
BuildID   20140417004002
Version   28.1
ro.build.version.incremental=eng.cltbld.20140417.115200
ro.build.date=Thu Apr 17 11:52:06 EDT 2014
Tarako
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #7)
> Created attachment 8408600 [details]
> logcat_1_browser OOMs when trying to create a room.txt
> 
> Running that web page, I ran into bug 998075
> 
> When trying to create a room, I OOM'ed within the browser app
> 
> Gaia      a8d2d399f2939f4845abaa0df57abab241a2c782
> Gecko    
> https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d97dad54cb61
> BuildID   20140417004002
> Version   28.1
> ro.build.version.incremental=eng.cltbld.20140417.115200
> ro.build.date=Thu Apr 17 11:52:06 EDT 2014
> Tarako

Note - we need to make sure we test each app used for input=file here, as there could be a different problem as a root cause on a per app basis. Can we indicate reproducibility on a per app basis?
(In reply to Jason Smith [:jsmith] from comment #6)
> Can we reproduce this using this test page here?
> 
> http://mozilla.github.io/qa-testcase-data/webapi/filemanagement/
> fileUploadTest.html

Removing QA wanted as this request has been fulfilled by comment 7.
Keywords: qawanted
Same root cause as bug 996141.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 996141
Whiteboard: 1.3tarakorun2, OOM, [c=memory p= s= u=] [MemShrink:P3] → 1.3tarakorun2, OOM, [c=memory p= s=2014.04.25 u=] [MemShrink:P3]
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.