Closed Bug 996333 Opened 7 years ago Closed 4 years ago

[webvtt] Dispatch TextTrackCue enter and exit events

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 882718

People

(Reporter: rillian, Assigned: reyre)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-needed)

When their display state changes, individual TextTrackCue objects should queue 'enter' and 'exit' events when their display state changes as playback advances.

http://www.whatwg.org/specs/web-apps/current-work/#cue-events
Blocks: webvtt
Blocks: 882718
I'll get a patch ready for this as well since we're tackling cuechange events now.
QA Contact: rick.eyre
Assignee: nobody → rick.eyre
QA Contact: rick.eyre
I'm looking into this since I need this event to be implemented. Just firing the events is easy, but doing it in the exact order required by the spec[1] probably requires that we move this logic to HTMLMediaElement.

I'm planning to implement this in the relatively inefficient way described by the spec (generate three lists of cues, generate events, sort events, sort tracks, etc.). We can optimize after it's correct.

[1] https://html.spec.whatwg.org/multipage/embedded-content.html#time-marches-on
Component: Audio/Video → Audio/Video: Playback
Blocks: 1131952
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 882718
You need to log in before you can comment on or make changes to this bug.